Make WordPress Core

Opened 2 years ago

Closed 2 years ago

Last modified 2 years ago

#55790 closed defect (bug) (invalid)

RTL problem in WordPress 6

Reported by: mralidoosti's profile mralidoosti Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Administration Keywords:
Focuses: rtl, administration Cc:

Description

When using RTL languages ​​in WordPress 6, The admin dashboard (wp-admin) is not RTL.
https://mr-alidoosti.com/img/1.png

This is because the dir ="rtl‌" tag is not added to the structure.
https://mr-alidoosti.com/img/2.png

Attachments (3)

1.png (189.6 KB) - added by mralidoosti 2 years ago.
image (5).png (178.4 KB) - added by sumitsingh 2 years ago.
SS in my staging site with 6.0 RC4
image (6).png (167.0 KB) - added by sumitsingh 2 years ago.
Actually user needed like this with RTL

Download all attachments as: .zip

Change History (13)

@mralidoosti
2 years ago

#1 @costdev
2 years ago

  • Keywords needs-testing added; needs-dev-note removed

This ticket was mentioned in Slack in #core-test by costdev. View the logs.


2 years ago

#3 @costdev
2 years ago

  • Keywords has-testing-info added

Issue Reproduction Report

Environment

  • Server: Apache (Linux)
  • WordPress: 6.0-RC4
  • Browser: Chrome 101.0.4951.64 and Firefox 100.0.2
  • OS: Windows 10
  • Theme: Twenty Twenty-One and Twenty Twenty-Two
  • Plugins: None activated

Steps

  1. Install and activate the WordPress Beta Tester plugin.
  2. Navigate to Tools > Beta Testing.
  3. Select Bleeding Edge and Release candidates only. Click Save Changes.
  4. If your site isn't already in an RTL language:
    • Navigate to Settings -> General.
    • Select an RTL language, such as Arabic, from the list.
    • Click Save Changes.
  5. Navigate to Dashboard > Updates (the 🎨 icon, then the second sub-menu item).
  6. Click the blue button that shows 6.0-RC4.
  7. Navigate to Dashboard > Home (the 🎨 icon, then the first sub-menu item).

If the screen looks like this, with the text aligned left-to-right, then the issue has been reproduced. Otherwise, the issue has not been reproduced.

Results

  1. Could not reproduce the issue. ❌

#4 @sumitsingh
2 years ago

  • Keywords has-testing-info removed

Hey,

I have checked on our end and as per @mralidoosti should RTL backend but it is not doing becuase it is not added dir ="rtl‌" tag in HTML tag.

Also i can see no anywhere added RTL on WordPress Persian language as of now.
here example https://fa.wordpress.org/support/

So i think need to think about this ticket by core team.

@sumitsingh
2 years ago

SS in my staging site with 6.0 RC4

@sumitsingh
2 years ago

Actually user needed like this with RTL

#5 @sumitsingh
2 years ago

  • Keywords dev-feedback has-dev-note added; needs-testing removed

#6 @costdev
2 years ago

  • Keywords has-testing-info needs-patch added; has-dev-note removed

To clarify the has-dev-note keyword:

has-dev-note

A dev note has been published on the
make core blog outlining this change.
This change provides significant new
functionality, a large refactor, or
includes a breaking change.

Re-adding the has-testing-info keyword so that testers can refer to these when testing a patch.

Last edited 2 years ago by costdev (previous) (diff)

This ticket was mentioned in Slack in #core by costdev. View the logs.


2 years ago

#8 @ocean90
2 years ago

  • Keywords dev-feedback has-testing-info needs-patch removed
  • Milestone Awaiting Review deleted
  • Resolution set to invalid
  • Status changed from new to closed

To ensure a site is properly setup for RTL the translation of the ltr string needs to be rtl. For Persian it was not but that's now corrected, see https://translate.wordpress.org/projects/wp/dev/fa/default/?filters%5Bstatus%5D=either&filters%5Boriginal_id%5D=40305&sort%5Bby%5D=translation_date_added&sort%5Bhow%5D=desc

Marking as invalid since it's not an issue with core but rather an incorrect translation.

This ticket was mentioned in Slack in #core by costdev. View the logs.


2 years ago

#10 @sabernhardt
2 years ago

Likewise, the following 16 languages do not have either ltr or rtl for their translations:

  • Latvian
  • Albanian
  • Macedonian
  • Saraiki
  • Bulgarian
  • Punjabi
  • Hindi
  • Dzongkha
  • Cebuano (has a capital I)
  • Breton
  • Ossetic
  • Yoruba
  • Oriya
  • Balochi Southern
  • Fulah
  • Shqip (Kosovo)

I ordered these by percentage completed (the first four already meet the 90% threshold for the language pack, and Bulgarian is close).

Version 0, edited 2 years ago by sabernhardt (next)
Note: See TracTickets for help on using tickets.