Make WordPress Core

Opened 2 years ago

Closed 22 months ago

#55792 closed defect (bug) (duplicate)

Block theme loading mechanism

Reported by: jivansoft's profile jivansoft Owned by:
Milestone: Priority: normal
Severity: major Version:
Component: Editor Keywords:
Focuses: template Cc:

Description

Hi,

We have checked and found that in the "wp-includes/template-canvas.php" file, you have called the function "get_the_block_template_html()" above the header that breaks the flow of the calling hooks like ('get_header, wp_enqueue_scripts, wp_header').

For example, If we add any "the_content" hook inside the "wp_enqueue_scripts" hook, then the "the_content" hook does not apply for the get post content.

Change History (3)

#1 @sabernhardt
2 years ago

  • Component changed from General to Editor

#2 @andykeith
22 months ago

I believe this is a duplicate of #55902.

#3 @sabernhardt
22 months ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #55902.

Thanks! I think you're right :)

And 55902 has discussion, so I'll close this ticket as the duplicate.

Note: See TracTickets for help on using tickets.