Make WordPress Core

Opened 2 years ago

Closed 23 months ago

#55810 closed defect (bug) (fixed)

Twenty Ten: Unbump version number due to lack of functional changes.

Reported by: peterwilsoncc's profile peterwilsoncc Owned by: peterwilsoncc's profile peterwilsoncc
Milestone: 6.0.1 Priority: normal
Severity: normal Version:
Component: Bundled Theme Keywords: fixed-major
Focuses: Cc:

Description

In [53418] for #55754 the Twenty Ten version number was bumped to 3.7.

This bumping was incorrect as there were no functional changes to the theme during the 6.0 release cycle.

The current theme version needs to be returned to 3.6. As the package on wordpress.org/downloads does not include Twenty Ten, there should not be any problems unbumping the theme as 3.7 is unreleased.

Props @desrosj for discovering this.

Attachments (3)

issue-1.png (719.4 KB) - added by ravipatel 2 years ago.
twentyten Theme version as per wordpress.org
version-issue.png (870.1 KB) - added by ravipatel 2 years ago.
twentyten Theme version as per installed theme
55810.diff (1.8 KB) - added by costdev 2 years ago.
Un-bump Twenty Ten from 3.7 to 3.6, remove changelog entry.

Download all attachments as: .zip

Change History (12)

@ravipatel
2 years ago

twentyten Theme version as per wordpress.org

@ravipatel
2 years ago

twentyten Theme version as per installed theme

#1 @ravipatel
2 years ago

@peterwilsoncc are you using development version?
I have same issue when i used development version and updated with WordPress 6.0.

@costdev
2 years ago

Un-bump Twenty Ten from 3.7 to 3.6, remove changelog entry.

#2 @peterwilsoncc
2 years ago

  • Owner set to peterwilsoncc
  • Resolution set to fixed
  • Status changed from new to closed

In 53448:

Budled themes: Revert the Twenty Ten theme version to 3.6.

No functional changes were made to Twenty Ten during the WordPress 6.0 release cycle so the theme version bump is not needed. The "tested up to" header change is maintained.

Follow up to and partial revert of [53418].

Props desrosj, ravipatel, costdev.
Fixes #55810.
See #55754.

#3 @peterwilsoncc
2 years ago

  • Keywords fixed-major added
  • Resolution fixed deleted
  • Status changed from closed to reopened

Reopening for merging to the 6.0 branch.

#4 @desrosj
2 years ago

Thanks for handling this, all!

I was going to backport [53448] and close this out, but it seems that themes are different than plugins and you can't just push a readme.txt file update (at least not with the access committers have to upload new versions).

I think we'll need to just follow up via a meta ticket. Leaving this open until that gets handled.

#5 @SergeyBiryukov
23 months ago

In 53648:

Bundled Themes: Revert the Twenty Ten theme version to 3.6.

No functional changes were made to Twenty Ten during the WordPress 6.0 release cycle so the theme version bump is not needed. The "Tested up to" header change is maintained.

Follow-up to and partial revert of [53418].

Props desrosj, ravipatel, costdev, peterwilsoncc.
Merges [53448] to the 6.0 branch.
See #55810, #55754.

#6 @SergeyBiryukov
23 months ago

The backport is done in [53648]. Keeping the ticket open for now to address comment:4.

This ticket was mentioned in Slack in #core by sergey. View the logs.


23 months ago

#8 @desrosj
23 months ago

I've created Meta-6397 to address this.

#9 @desrosj
23 months ago

  • Resolution set to fixed
  • Status changed from reopened to closed

Looks like it's currently not possible to update the Tested up to: value without an actual theme update.

Closing this out and we can update it when there are source code changes. If anyone feels it's important to update this value, we could look to get some small tickets resolved for the theme and push an update to Twenty Ten only. #52545 and #52546 look like good candidates for that.

Note: See TracTickets for help on using tickets.