Make WordPress Core

Opened 2 years ago

Closed 3 weeks ago

#55815 closed defect (bug) (wontfix)

Twenty-Twenty-Two: Post Format Gallery

Reported by: mukesh27's profile mukesh27 Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Bundled Theme Keywords: has-screenshots 2nd-opinion close
Focuses: ui, css Cc:

Description

Twenty-Twenty-Two does not include gallery columns classes for the frontend. Another default theme has this class and it working fine for them.

.gallery-columns-2 .gallery-item {
	max-width: 50%;
}

.gallery-columns-3 .gallery-item {
	max-width: 33.33%;
}

.gallery-columns-4 .gallery-item {
	max-width: 25%;
}

.gallery-columns-5 .gallery-item {
	max-width: 20%;
}

.gallery-columns-6 .gallery-item {
	max-width: 16.66%;
}

.gallery-columns-7 .gallery-item {
	max-width: 14.28%;
}

.gallery-columns-8 .gallery-item {
	max-width: 12.5%;
}

.gallery-columns-9 .gallery-item {
	max-width: 11.11%;
}

Attachments (1)

Post Format_ Gallery – 3 column.png (205.7 KB) - added by mukesh27 2 years ago.

Download all attachments as: .zip

Change History (11)

#1 @nidhidhandhukiya
2 years ago

Hello @mukesh27
Can you please provide steps for reproduce this issue.

#2 @mukesh27
2 years ago

Yes sure.

This ticket was mentioned in Slack in #core-test by ironprogrammer. View the logs.


22 months ago

#4 @poena
22 months ago

@mukesh27 Hi!
Is the intention to support classic content in the full site editing theme?
I have not followed this closely, has there been a decision to do this?
Pinging @jffng who may know.

#5 @ironprogrammer
22 months ago

  • Keywords needs-patch removed

Holding off patch requirement pending further review.

For context raised during <test-triage>, please see https://wordpress.slack.com/archives/C03B0H5J0/p1655225700691669

#6 @jffng
22 months ago

Hi there, thanks for the report.

It was decided early on to not add CSS for classic content like post formats to the theme, since this was the first default block theme.

This ticket was mentioned in Slack in #core-themes by ironprogrammer. View the logs.


22 months ago

#8 @sabernhardt
22 months ago

  • Keywords 2nd-opinion added

It's not the Gallery post format, but the Gallery shortcode output. I still can create that with a Classic block, which I remember suggesting to someone who wanted to drag and drop gallery items.

Of course, you may not want to support that either in the theme.

#9 @karmatosed
3 weeks ago

  • Keywords close added

To summarize what I think has happened on this ticket:

  • @jffng explained that, a decision was made early to not add CSS for classic content like post formats to the theme.
  • @sabernhardt confirmed the issue is around the Gallery shortcode output and the supported workaround.
  • There is a drive to focus on bugs around older default themes and this doesn't seem to fall into that category, close out anything else for now which has an agreed closing point.

Based on these points, I am going to recommend close and put the keyword up for that recommendation. We can always review and feedback is very welcome. Thank you for everyone's collaboration so far.

#10 @karmatosed
3 weeks ago

  • Milestone Awaiting Review deleted
  • Resolution set to wontfix
  • Status changed from new to closed

As there seems no counter to this right now, let's proceed with closing. Thank you everyone.

Note: See TracTickets for help on using tickets.