Make WordPress Core

Opened 2 years ago

Closed 22 months ago

#55816 closed defect (bug) (wontfix)

upload animation webp return 500 error

Reported by: tianshi2's profile tianshi2 Owned by:
Milestone: Priority: normal
Severity: normal Version: 6.1
Component: Media Keywords: dev-feedback reporter-feedback
Focuses: Cc:

Description

upload animation webp return 500 error

Attachments (2)

Screen Recording 2022-08-03 at 04.32.58 PM (1).mp4 (78.1 KB) - added by adamsilverstein 22 months ago.
animated-webp-supported.webp (36.5 KB) - added by adamsilverstein 22 months ago.

Download all attachments as: .zip

Change History (4)

#1 @adamsilverstein
2 years ago

Hi @tianshi2 thanks for the bug report, welcome to WordPress Trac!

Can you provide a sample image that causes the error?

Can you confirm the error still occurs if you disable all plugins?

#2 @adamsilverstein
22 months ago

  • Milestone Awaiting Review deleted
  • Resolution set to wontfix
  • Status changed from new to closed

Hi @tianshi2 -

I tested this out with LibGD enabled and reproduced the error you mentioned "The server cannot process the image". This makes sense because _LibGD only supports single frame images_.

I then enabled Imagick and tested again, the WebP uploaded correctly, showed as animated in the media library, however I noticed that sub sized images were *not* created correctly for this image.

Unfortunately, these issues likely need to be fixed upstream. The maintainer of GD has expressed liking the idea of adding support for adding WebP animated format, however it sounds like a significant effort. See https://github.com/libgd/libgd/issues/648

I also noticed there was a recent bug fix in GD for parsing animated WebP so maybe some support is now in place, see https://github.com/friendica/friendica/pull/11546

Closing this as won't fix since it is more of an upstream library than a WordPress issue.

Note: See TracTickets for help on using tickets.