Make WordPress Core

Opened 23 months ago

Closed 22 months ago

Last modified 21 months ago

#55826 closed defect (bug) (reported-upstream)

the first day of the week is Monday

Reported by: philll1234's profile philll1234 Owned by:
Milestone: Priority: normal
Severity: critical Version: 5.9
Component: Editor Keywords:
Focuses: Cc:

Description

Hello!
Now on WordPress, the first day of the week is Sunday (If you open the calendar with editing, I attach the link).
In the settings, the first day of the week is MONDAY.
But for some reason, as a result, the first day of the week in the calendar is “Sunday” – Please help me fix it for Monday….
https://ibb.co/6ZbbpmV

I disabled all plugins, cleared the cache, tried on different sites - the same problem everywhere ...(

Change History (8)

#1 @SergeyBiryukov
23 months ago

  • Component changed from General to Editor

#2 @philll1234
23 months ago

I checked everything - it doesn't work. I attach screenshots:

  1. I have installed the most up-to-date and fresh theme - https://ibb.co/nCx0Sz9
  2. All plugins are disabled - https://ibb.co/2614B80
  3. The problem is still relevant - https://ibb.co/cCxXGzZ

(Sunday is the first in the list, on the left, and then it's Monday).
In the settings is the first day of the week - Monday - screenshot - https://ibb.co/CmFkvD9

#3 @SergeyBiryukov
23 months ago

  • Milestone changed from Awaiting Review to 6.0.1

Hi there, welcome to WordPress Trac! Thanks for the ticket.

I was able to reproduce the issue. Moving to the milestone for investigation.

#4 @sabernhardt
23 months ago

Also reported on GitHub: GB41078

#5 @sabernhardt
22 months ago

  • Milestone 6.0.1 deleted
  • Resolution set to reported-upstream
  • Status changed from new to closed
  • Version changed from 6.0 to 5.9

PR 41648 was merged.

#6 follow-up: @goaroundagain
21 months ago

@sabernhardt Just installed 6.0.1, but this quite annoying issue has not been fixed. Do we have to wait until 6.1 to get a fix for this? I know, in American the week starts Sunday but a large portion of the world (see http://chartsbin.com/view/41671) it starts Monday or even Saturday.

#7 in reply to: ↑ 6 ; follow-up: @SergeyBiryukov
21 months ago

Replying to goaroundagain:

Just installed 6.0.1, but this quite annoying issue has not been fixed. Do we have to wait until 6.1 to get a fix for this?

Indeed, it looks like this was not included in the list of block editor fixes for 6.0.1. I see you've already left a comment on the issue, let's hope the Editor team prioritizes the PR for 6.0.2.

#8 in reply to: ↑ 7 @philll1234
21 months ago

Replying to SergeyBiryukov:

Replying to goaroundagain:

Just installed 6.0.1, but this quite annoying issue has not been fixed. Do we have to wait until 6.1 to get a fix for this?

Indeed, it looks like this was not included in the list of block editor fixes for 6.0.1. I see you've already left a comment on the issue, let's hope the Editor team prioritizes the PR for 6.0.2.

hello. for me, too, when updating, nothing was fixed, it's a pity. I hope that this will be fixed at least someday..

Note: See TracTickets for help on using tickets.