Make WordPress Core

Opened 2 years ago

Closed 21 months ago

Last modified 21 months ago

#55830 closed defect (bug) (worksforme)

Rover IDX broken in WordPress 6.0

Reported by: stevemullen's profile stevemullen Owned by:
Milestone: Priority: normal
Severity: normal Version: 6.0
Component: Bootstrap/Load Keywords:
Focuses: Cc:

Description

Rover IDX uses do_parse_request and the_posts to hook into a 404 condition, and provide content when certain criteria are met. This is not working in 6.0. We don't even get to the_posts - it's never fired. Is there new 404 handling that skips the_posts? I know there were performance changes in 6.0 - I suspect one of those changes is skipping the_posts when 404 is detected.

https://demo.roveridx.com/ma/dennis/58-featherbed-lane/ - this url should display a fully formed real estate listing.

Change History (7)

#1 @SergeyBiryukov
2 years ago

  • Milestone changed from Awaiting Review to 6.0.1

Hi there, welcome to WordPress Trac! Thanks for the ticket.

This appears to be related to [52814] / #10886, moving to the milestone for visibility. This might be the expected behavior when the do_parse_request filter returns false, but could use some testing and confirmation.

#2 @stevemullen
2 years ago

I did add a change to have the Rover IDX plugin call do_parse_request and return true, but this did not resolve the problem.

#3 @SergeyBiryukov
2 years ago

  • Milestone changed from 6.0.1 to 6.0.2

Thanks for the follow-up! Looks like this still needs investigation and testing. With 6.0.1 RC1 coming tomorrow, moving to 6.0.2 for now.

#4 @SergeyBiryukov
22 months ago

  • Milestone changed from 6.0.2 to 6.1

Looks like this did not get any further traction yet. With 6.0.2 RC1 coming today, moving to 6.1 for now.

Last edited 22 months ago by SergeyBiryukov (previous) (diff)

#5 follow-up: @desrosj
21 months ago

  • Keywords reporter-feedback added
  • Milestone changed from 6.1 to Future Release

@stevemullen is there any way that you could write a unit test or provide a code snippet that can be used to reproduce the problem with some detailed steps?

I'm having trouble reproducing, and it looks like the URL you provided is now redirecting to a proper page. Is this intentional from a fix on your part, or does this indicate it's not working correctly?

I'm going to move this to Future Release. Unless a (safe) fix presents itself before Tuesday, this one will likely require more discussion and testing. Especially since the actually issue and the cause are not yet apparent.

#6 in reply to: ↑ 5 @stevemullen
21 months ago

  • Resolution set to worksforme
  • Status changed from new to closed

I agree - this is working now. I'm closing.

Replying to desrosj:

@stevemullen is there any way that you could write a unit test or provide a code snippet that can be used to reproduce the problem with some detailed steps?

I'm having trouble reproducing, and it looks like the URL you provided is now redirecting to a proper page. Is this intentional from a fix on your part, or does this indicate it's not working correctly?

I'm going to move this to Future Release. Unless a (safe) fix presents itself before Tuesday, this one will likely require more discussion and testing. Especially since the actually issue and the cause are not yet apparent.

Last edited 21 months ago by stevemullen (previous) (diff)

#7 @desrosj
21 months ago

  • Keywords reporter-feedback removed
  • Milestone Future Release deleted

Thanks for confirming!

Note: See TracTickets for help on using tickets.