Make WordPress Core

Opened 2 years ago

Closed 22 months ago

Last modified 22 months ago

#55861 closed defect (bug) (duplicate)

Daylight Savings Time Incorrect for Indiana in WordPress 6

Reported by: midipedalboards's profile midipedalboards Owned by:
Milestone: Priority: normal
Severity: normal Version: 6.0
Component: Date/Time Keywords:
Focuses: Cc:

Description

Hello,

Don’t know how long this has existed as an issue because I’ve never had any reason to question it until now.

Using a plugin that echos the date a task was completed at approx 11:30 PM Indianapolis Indiana time on May 27, 2022 the resulting echo output of the date as May 28, 2022.

So I checked my server setting at it was set correctly. I also check the WordPress admin area:

Settings > General > Timezone

which is set to Indiana - Indianapolis (which is correct for me) and I see where it says right below that:

“ Universal time is 2022-05-28 03:56:26. Local time is 2022-05-27 23:56:26.

This timezone is currently in daylight saving time.
This timezone does not observe daylight saving time.”

Indiana does recognize Daylight Savings Time and has since April 6, 2016

Verified here: https://faqs.in.gov/hc/en-us/articles/115005225448-Indiana-Time-Zone-Information

Attachments (2)

5A496E9D-65C8-479C-92BF-6E5DB9D36A4A.jpeg (253.5 KB) - added by midipedalboards 2 years ago.
Screenshot of the daylight savings time erroneous information
timezone-Indianapolis.png (9.0 KB) - added by sabernhardt 2 years ago.
my timezone settings, about 90 minutes later

Download all attachments as: .zip

Change History (8)

@midipedalboards
2 years ago

Screenshot of the daylight savings time erroneous information

@sabernhardt
2 years ago

my timezone settings, about 90 minutes later

#1 @sabernhardt
2 years ago

  • Component changed from Administration to Date/Time

Thanks for the report!

My settings did not match yours. Could you check again within an hour before and after midnight?

I thought it might relate to the fact that the details do not update until you Save Changes, but saying that the location is in DST and does not observe it makes no sense in any timezone :)

#2 @Rarst
2 years ago

WordPress pulls time zones information from PHP. If the data is incorrect, it is likely that PHP instance and/or its time zones database is outdated or otherwise invalid.

#3 @zodiac1978
22 months ago

I suspect that the server does not have the timezones installed correctly.
https://hackage.haskell.org/package/tzdata

#4 @iStag
22 months ago

I also encountered the same error under Xampp 8.1.2
I reinstall WordPress every month for my students and the error first appeared to me two weeks ago with the new version WP 6. Before that in the last 4-5 months we used the same Xampp environment and had no timezone problem so far

#5 @Rarst
22 months ago

  • Milestone Awaiting Review deleted
  • Resolution set to wontfix
  • Status changed from new to closed

I've run this through bunch of PHP versions and there is an issue with reporting future transitions on PHP 8.1.0 to 8.1.5 inclusive. See https://3v4l.org/dT94b

As above, there is nothing we can do about it on WordPress level. We just work with data as provided by PHP language.

Just for completeness, I've looked at changes history and related code had no changes in 3 years, so any observations linking it to WP 6 are coincidence.

Related #53780

#6 @Rarst
22 months ago

  • Resolution changed from wontfix to duplicate

Duplicate of #53780.

Note: See TracTickets for help on using tickets.