Make WordPress Core

Opened 2 years ago

Last modified 4 weeks ago

#55934 reopened defect (bug)

Twenty Twenty: "Add citation" text font-weight issue in Quote block

Reported by: kmadhak's profile kmadhak Owned by:
Milestone: Awaiting Review Priority: normal
Severity: normal Version: 5.3
Component: Bundled Theme Keywords: needs-patch
Focuses: ui, css Cc:

Description

In Twenty Twenty Theme, when we add a text on "Add citation" in Quote block and make the text as italic then in editor side it is visible as italic without font-weight. But when we see the same formatted text at front side, then it is with italic and having font-weight as bolder which is different from editor side.

Steps to replicate:
1: Activate the Twenty Twenty Theme
2: Add Quote block
3: Add text in "Add citation" section
4: Select the added text and make them as italic
5: Save Page/Post
6: View the page/post at front side

For better understanding I provide video attachment.

Thank You.

Attachments (3)

Untitled.mp4 (8.0 MB) - added by kmadhak 2 years ago.
font-weight.png (137.3 KB) - added by mukesh27 2 years ago.
#55934.patch (353 bytes) - added by kajalgohel 2 years ago.
patch added for font-weight in front side.

Change History (15)

@kmadhak
2 years ago

#1 @mukesh27
2 years ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #55931.

#2 @kmadhak
2 years ago

  • Resolution duplicate deleted
  • Status changed from closed to reopened

Hello @mukesh27,

As we can see that, the ticket which you have mentioned as main ticket (https://core.trac.wordpress.org/ticket/55931) having font-style issue, which is totally different from the issue which I have reported here that is of font-weight issue, please check it once and let me know if there is anything.

Thank you.

#3 @mukesh27
2 years ago

@kmadhak Thanks for reopen. Yes it's different ticket.

As i see in my test the font weight for same 600

@mukesh27
2 years ago

#4 follow-up: @kmadhak
2 years ago

Hello @mukesh27,

I have attached the video and provided the steps which help you to reproduce the issue, please find the attached video with this ticket and you can refer the steps which I have mentioned in description above.

Thank you.

#5 in reply to: ↑ 4 @hasanuzzamanshamim
2 years ago

Replying to kmadhak:

I tested on my local from the trunk and everything is working as expected.

https://prnt.sc/dOjD8xIa2OOb

#6 follow-up: @kmadhak
2 years ago

Hello @hasanuzzamanshamim,

As I have seen your screenshot, I guess you are using Twenty Twenty Two Theme, but you can regenerate this issue in Twenty Twenty Theme which I have mentioned in my description and title as well in this ticket.

Thank you.

#7 in reply to: ↑ 6 @hasanuzzamanshamim
2 years ago

Replying to kmadhak:

Oops! Thanks for pointing it out, Now I got the issue.

#8 @hasanuzzamanshamim
2 years ago

Twenty Twenty's style.css has

cite em,
cite i {
   font-weight: bolder;
}

also on the style-rtl.css file needs to fix.

@kajalgohel
2 years ago

patch added for font-weight in front side.

#9 @kajalgohel
2 years ago

  • Keywords has-patch added; needs-patch removed

#10 @sabernhardt
2 years ago

  • Keywords needs-patch added; has-patch removed
  • Milestone set to Awaiting Review
  • Version changed from 6.0 to 5.3

Making the font-weight bolder on the front end was a clear design decision from the beginning of the theme. People probably should expect that to remain the same, especially if they do not use the block editor.

Even so, the editor would need to reflect the bolder style.

#11 @kajalgohel
2 years ago

Hello @sabernhardt

As per user point of view and for consistency, editor and front side should be similar.
I think whatever changes we are performing at the editor side, it should reflect on the front side.

Thanks

This ticket was mentioned in Slack in #core-themes by karmatosed. View the logs.


4 weeks ago

Note: See TracTickets for help on using tickets.