Make WordPress Core

Opened 22 months ago

Closed 3 months ago

#56005 closed defect (bug) (duplicate)

Twenty Twenty One: Pullquote Block: Font Size Change Not reflected in editor and Frontend

Reported by: nithins53's profile nithins53 Owned by:
Milestone: Priority: normal
Severity: normal Version: 6.0
Component: Bundled Theme Keywords: has-patch
Focuses: ui, css Cc:

Description

In the Twenty Twenty One theme, when we add a pullquote block and change the font size, the change is not reflected in the editor nor the front end.

Steps to replicate:

  1. Activate Twenty Twenty One Theme
  2. Insert Pullquote block
  3. Change Font Size

For more information, screen recording link attached below.

https://www.loom.com/share/df25f75841154901a5482d4a4fb0e75a

Thank You.

Attachments (1)

#56005.patch (1.1 KB) - added by umesh84 22 months ago.
added patch

Download all attachments as: .zip

Change History (10)

#1 @nithins53
22 months ago

  • Keywords needs-patch added

@umesh84
22 months ago

added patch

#2 @nithins53
22 months ago

  • Keywords has-patch added; needs-patch removed

This ticket was mentioned in Slack in #core by nithins53. View the logs.


22 months ago

#4 @audrasjb
22 months ago

  • Keywords needs-testing added

Hello, thanks for the ticket and the related patch,

It would be nice to test this patch with a previous version of WordPress (like 5.6 for example) to make sure removing these css variables is not breaking existing sites.

Thanks

#5 @kajalgohel
22 months ago

Hello @audrasjb,

I have reproduced this issue on WP 5.9 and the issue is resolved with the given patch and works fine. Checked this issue on cross browsers as well and it is working well with latest versions of chrome, safari and firefox.

Steps to reproduce:
1: Activate the Twenty Twenty One Theme on WP 5.9
2: Add Pullquote block
3: Add "Add Quote" text and "Add Citation" text
4: Choose Typography Size Option and change font size

For better understanding, I provide video attachment link
Video link: https://share.cleanshot.com/n8CUpxnw249M6Jfamp4e

Thank you.

#6 @audrasjb
22 months ago

Thanks for testing this @kajalgohel!
However we also need to make sure it doesn't break existing websites with existing typography changes on existing blocks :)

#7 @adamwood
22 months ago

  • Keywords changes-requested added; needs-testing removed

I've tested the patch with WordPress 5.6.8 and the latest version of the Twenty Twenty One Theme installed, and the patch does indeed break the styling of existing Pullquotes. The size of the text goes from 32px without the patch to 20px with it applied.

Editor before:
https://cldup.com/oUsiYBqPSp.jpg

Editor after:
https://cldup.com/HDiiNXwoXk.jpg

Post before:
https://cldup.com/pShtCL8HKz.jpg

Post after:
https://cldup.com/ybtA_18obw.jpg

As you can see on 5.6.8 there are no font size controls for this block. Looks like we'll need a different solution for this sorry.

#8 @nithins53
22 months ago

@adamwood Thank you for testing the patch. Yes, we need some other solution to fix this issue.

#9 @sabernhardt
3 months ago

  • Keywords changes-requested removed
  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

This ticket was opened first, but the issue is part of #57854 if you would like to participate there.

Note: See TracTickets for help on using tickets.