Make WordPress Core

Opened 2 years ago

Closed 3 months ago

Last modified 2 months ago

#56015 closed defect (bug) (worksforme)

Twenty Twenty-One: Preview Changes Background Colour To Default

Reported by: mrfoxtalbot's profile mrfoxtalbot Owned by:
Milestone: Priority: normal
Severity: minor Version:
Component: Bundled Theme Keywords:
Focuses: Cc:

Description

When using Twenty Twenty-One (have only tested on this theme), if you select a different background colour for the site in Customizer > Colors & Backgrounds the page is the correct colour in normal view preview but reverts to the default colour when previewed in Tablet or Mobile views.

Steps to reproduce:

  • Change to Twenty Twenty-One theme
  • Go to Appearance > Colors & Backgrounds
  • Edit background colour to anything of your choosing
  • Open the editor for a page
  • Click Preview
  • Choose Tablet or Mobile

What I expected to happen:

I expected to see the site in the same colour as I have just chosen in the customizer

What actually happened:

Site shows with default background (#D1E4DD) regardless of what colour has been chosen

Attachments (1)

Screen Capture on 2022-06-20 at 14-34-27.mp4 (158.4 KB) - added by mrfoxtalbot 2 years ago.
Twenty Twenty-One Preview Changes Background Colour To Default

Download all attachments as: .zip

Change History (6)

@mrfoxtalbot
2 years ago

Twenty Twenty-One Preview Changes Background Colour To Default

#2 @poena
18 months ago

I have not been able to reproduce this on other themes (though most of the themes I tested did not change the background color of the editor at all.

It is possibly due to how the background color is handled to work with the dark mode.

#3 @karmatosed
3 months ago

  • Keywords close added

I also find myself unable to reproduce. This might be due to needing more steps and if those can be provided I am happy to see if I can. However, until that happens I am going to recommend closing this and moving it into a resolution. Thank you everyone for the collaboration on this.

#4 @mrfoxtalbot
3 months ago

  • Resolution set to worksforme
  • Status changed from new to closed

I just re-tested this and it appears to be solved.

#5 @desrosj
2 months ago

  • Keywords close removed
  • Milestone Awaiting Review deleted
Note: See TracTickets for help on using tickets.