Make WordPress Core

Opened 23 months ago

Closed 2 months ago

#56104 closed enhancement (wontfix)

Twenty Twenty: Button Text is coming in uppercase only

Reported by: varshil151189's profile varshil151189 Owned by:
Milestone: Priority: normal
Severity: normal Version: 5.3
Component: Bundled Theme Keywords: close
Focuses: css Cc:

Description

Hello Team,

In Twenty Twenty theme, when we add Button block in editor side, Text is always coming in Uppercase at both side (Frontend and Backend).

For more information, please find video below:

Video URL: https://share.cleanshot.com/7bXIxswEi3ta4LoMumcN

Thank you.

Attachments (1)

#56104.patch (1.9 KB) - added by kajalgohel 23 months ago.
added patch for adding text-transform:none of button text

Download all attachments as: .zip

Change History (9)

@kajalgohel
23 months ago

added patch for adding text-transform:none of button text

#1 @kajalgohel
23 months ago

  • Keywords has-patch needs-testing added; needs-patch removed

#2 @kajalgohel
23 months ago

Hello @varshil151189,

Thanks for reporting this! In this buton text if you check there is one css text-transform:uppercase;. If it is not intentionally, we should replace that with text-transfrom: none then the issue is resolved.

#3 @sabernhardt
23 months ago

  • Focuses ui removed
  • Keywords needs-patch added; has-patch needs-testing removed
  • Type changed from defect (bug) to enhancement
  • Version changed from 6.0 to 5.3

Adding the all-caps styling was intentional in an early commit.

#49710 was going to reverse that decision, but uppercase was restored so people would not have it changed automatically. We could use this ticket to follow up on @kjellr's suggestion to create an optional button block style.

#4 @sabernhardt
23 months ago

#56102 was marked as a duplicate.

#5 @sabernhardt
23 months ago

#56103 was marked as a duplicate.

#7 @sabernhardt
11 months ago

  • Keywords close added; needs-patch removed

A custom block style from the theme would be easier to find, but [56000] makes the block's Letter Case setting work. I think this can be closed.

#8 @karmatosed
2 months ago

  • Milestone Awaiting Review deleted
  • Resolution set to wontfix
  • Status changed from new to closed

As this was recommended to be closed by @sabernhardt over 9 months ago, I am now going to do just that. I also agree that a custom block style is ideal now that issue is resolved. Due to this, marking as 'won't fix'.

Note: See TracTickets for help on using tickets.