Make WordPress Core

Opened 2 years ago

Closed 13 months ago

#56113 closed defect (bug) (worksforme)

Twenty Twenty: Button text font size issue occurs on editor side

Reported by: multidots1896's profile multidots1896 Owned by:
Milestone: Priority: normal
Severity: normal Version: 6.0
Component: Bundled Theme Keywords: has-patch
Focuses: Cc:

Description

Steps to reproduce :-
Activate Twenty Twenty theme.
Take a button block.
Align button to any left, center or right.
Then add font size it should not reflect on button on the editor side it should work properly on the user side.
If you make button alignment to none then this issue will not happen.

Please follow below video link:
https://share.cleanshot.com/HuW9FhHBSv0fl5P4uV7p

Attachments (4)

56113.patch (569 bytes) - added by multidots1896 2 years ago.
added patch
56113.1.patch (1.1 KB) - added by devtanbir 2 years ago.
Added patch
2020-large-button-center-6.0.png (127.4 KB) - added by sabernhardt 13 months ago.
extra div in editor in WordPress 6.0
2020-large-button-center-6.2.png (118.0 KB) - added by sabernhardt 13 months ago.
font-size is inherited in WordPress 6.2

Download all attachments as: .zip

Change History (6)

@multidots1896
2 years ago

added patch

#1 @SergeyBiryukov
2 years ago

  • Summary changed from In Twenty Twenty button text font size issue occur on editor side to Twenty Twenty: Button text font size issue occurs on editor side

@devtanbir
2 years ago

Added patch

@sabernhardt
13 months ago

extra div in editor in WordPress 6.0

@sabernhardt
13 months ago

font-size is inherited in WordPress 6.2

#2 @sabernhardt
13 months ago

  • Milestone Awaiting Review deleted
  • Resolution set to worksforme
  • Status changed from new to closed

Thanks for the report and patches!

This is apparently caused by the same extra div as reported for Twenty Seventeen on #56107.

I could not get that div in the editor in 6.2, so the font-size:inherit; works for me without editing the theme.

Note: See TracTickets for help on using tickets.