WordPress.org

Make WordPress Core

Opened 14 years ago

Closed 14 years ago

Last modified 14 years ago

#5616 closed defect (bug) (worksforme)

When you have over 20 pages, you cannot select the appropriate page parent

Reported by: jackgnic Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: General Keywords: page parent
Focuses: Cc:

Description

The drop down box where you select the Page Parent only has the facility to display 20 pages. Therefore if a user creates 20 pages in WordPress there too many pages for the drop down box to cope with and the user cannot Page Parent correctly.

Attachments (1)

6516.jpg (41.6 KB) - added by thee17 14 years ago.
screen shot

Download all attachments as: .zip

Change History (7)

#1 @jackgnic
14 years ago

  • Cc jackgnic added

#3 @thee17
14 years ago

  • Resolution set to worksforme
  • Status changed from new to closed

I cannot reproduce in IE7, Firefox 2 or 3, Safari 3 on Windows on WP 2.3.2 or 2.4-bleeding both fresh installs.

The default admin CSS limits the width of the box, so that it does not go over the edge of the screen.

#4 @jackgnic
14 years ago

  • Resolution worksforme deleted
  • Status changed from closed to reopened

It's not about the width of the box going over the edge of the screen... It's about the Size of the box not being able to display a list showing 20 pages in length. The drop down box only needs a scroll bar and the problem would be fixed easily.

I reproduced the problem in IE7, Firefox 2 and Safari.

@thee17
14 years ago

screen shot

#5 @thee17
14 years ago

  • Resolution set to worksforme
  • Status changed from reopened to closed

after about 25 entries there is a scroll-bar, in firefox it just puts it wider because it goes off the screen (for smaller sizes) you dont see ithe scroll bar. This was taken from 2.3.2. In 2.4/2.5 it is in a totally diferent spot so it probably wont need fixed in 2.6 as this is marked for.

#6 @westi
14 years ago

  • Milestone 2.6 deleted

Looking at the screenshots here and over on the forums this looks to me to be a browser chrome rendering issue rather than an issue with WordPress.

If you scroll down the list using the arrow keys you should see it scroll - the browser has unfortunately rendered it off the side of the screen but the scroll bar is there.

Note: See TracTickets for help on using tickets.