Make WordPress Core

Opened 23 months ago

Closed 18 months ago

Last modified 17 months ago

#56265 closed defect (bug) (invalid)

issue with unordered posts in pagination after deleting one post

Reported by: mikulabc's profile mikulabc Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Posts, Post Types Keywords: needs-testing has-testing-info
Focuses: ui, accessibility, administration Cc:

Description

/wp-admin/edit.php?post_status=pending&post_type=post&paged=3

if posts have the same "modified" date, wordpress randomizes the order of posts displayed in the pagination results, the page shows the posts in a fixed specific order before the deletion of a single post in the results list and after deleting one post, it shows a different order of items (see attachment example).

fix: it should stick to using a parameter to sort items fixed in an order if all have the same date and time and one gets deleted.

Attachments (2)

before.png (159.6 KB) - added by mikulabc 23 months ago.
after.png (146.8 KB) - added by mikulabc 23 months ago.

Download all attachments as: .zip

Change History (11)

@mikulabc
23 months ago

@mikulabc
23 months ago

#1 follow-up: @costdev
23 months ago

  • Keywords needs-testing reporter-feedback added

Hi @mikulabc, thanks for opening this ticket! To help make testing this issue easier, let's get some testing instructions on the ticket.

Last edited 22 months ago by costdev (previous) (diff)

#2 in reply to: ↑ 1 @mikulabc
23 months ago

  • Keywords needs-testing reporter-feedback removed

@costdev I was able to replicate the issue and the bug still randomizes the order, if you follow the test below you will get the same:

Testing Instructions

Steps to Reproduce

  1. ‼ Only view "All Posts", url: /wp-admin/edit.php?post_type=post
  2. Create 5 posts "Test 1" ..2,3,4,5 AND save as "pending" AND set the publish date to "2022/01/01 at 9:00 am"
  3. At this point, WordPress decided to give the posts a random order
  4. The current order of the posts that i have is Test "2,1,4,5,3" even though the order i created them was "1,2,3,4,5"
  5. Delete the 2nd post which is "Test 1"
  6. The order now is still correct "2,4,5,3" ("1" is missing, but WordPress keeps the order from the beginning)
  7. Delete another item, eg. "Test 4"
  8. WordPress decides to order the items completely different, the new order is "3,5,2".

Expected Results

  • 🐞❌ The remaining posts display in a different order than before.
Last edited 22 months ago by costdev (previous) (diff)

This ticket was mentioned in Slack in #accessibility by sabernhardt. View the logs.


23 months ago

#4 @costdev
22 months ago

  • Keywords needs-testing has-testing-info added

Thanks for adding more detail on how to reproduce the issue @mikulabc!

Reproduction Report

Environment

  • Server: Apache (Linux)
  • WordPress: 6.1-alpha-53344-src
  • Browser: Chrome 103.0.0.0
  • OS: Windows 10
  • Theme: Twenty Twenty-Two
  • Plugins: None activated

Actual Results (following these steps)

  • ❌ No bug. Posts are displayed in the order they were created: 1, 2, 3, 4, 5.
  • ✅ Same result (no bug). After deleting the second item in the list (Post 2): 1, 3, 4, 5.
  • ❌ No bug. After deleting the second remaining item (Post 3): 1, 4, 5.
  • Could not reproduce the issue.

Notes

  • Re-adding needs-testing and has-testing-info using instructions in comment 2 so that other contributors can try to reproduce this issue.

This ticket was mentioned in Slack in #accessibility by joedolson. View the logs.


20 months ago

This ticket was mentioned in Slack in #accessibility by ryokuhi. View the logs.


18 months ago

#7 @ryokuhi
18 months ago

Hello @mikulabc,

we reviewed this ticket again today during the Accessibility Team's weekly bug scrub.

We haven't been able to reproduce the bug yet, so we need feedback on your side once more.

Can you please share with us the following details, to see if they help us with reproducing your issue?

  • Operating system
  • Browser version
  • WordPress version
  • Active theme (tests should be done with the default theme, which currently is Twenty Twenty-Three)
  • Active plugins (tests should be done after deactivating all plugins if the issue shows up when a certain plugin is active the problem is usually due to the plugin itself)

We're waiting for feedback from @bgoewert: if he isn't able to reproduce the issue and we don't get back from the reporter, this ticket is a good candidate for close.

#8 @mikulabc
18 months ago

  • Resolution set to invalid
  • Status changed from new to closed

I couldn't reproduce it either, I will close this and I will open a new ticket if it happens again.

#9 @desrosj
17 months ago

  • Milestone Awaiting Review deleted
Note: See TracTickets for help on using tickets.