Make WordPress Core

Opened 21 months ago

Closed 20 months ago

Last modified 20 months ago

#56281 closed defect (bug) (invalid)

A <br> should not be removed

Reported by: bhs67's profile bhs67 Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: TinyMCE Keywords:
Focuses: Cc:

Description

Elementor --- Edit with Elementor > Text Editor > Paragraph > Text {tab} > enter text that includes <br> (br) in multiple places.
.
Later, the <br> (br) has been removed. I must re-enter the <br> (br) in all of the places they were before.
.
Per https://github.com/elementor/elementor/issues/18053 => Elementor Text Editor Widget uses the WordPress TinyMCE library for rich editing.

Attachments (5)

b99125a5185e329b3682214f4573035d.gif (580.7 KB) - added by audrasjb 21 months ago.
Capture d’écran 2022-07-24 à 17.33.55.png (319.3 KB) - added by audrasjb 21 months ago.
fo1.jpg (60.3 KB) - added by bhs67 21 months ago.
fo2.jpg (60.6 KB) - added by bhs67 21 months ago.
fo3.jpg (78.8 KB) - added by bhs67 21 months ago.

Download all attachments as: .zip

Change History (13)

#1 @audrasjb
21 months ago

  • Component changed from Formatting to TinyMCE
  • Keywords reporter-feedback added; needs-design-feedback removed
  • Version 6.0 deleted

Hello, welcome to WordPress Trac and thank you for opening this ticket,

I tried to reproduce the issue in TinyMCE but I wasn't able to reproduce it.
<br /> tags are not stripped, they are replaced visually with a line break. On the front end, <br /> tags are generated.

Can you please share a screenshot or two showing your issue?

See screenshots below with my tests.

@bhs67
21 months ago

@bhs67
21 months ago

@bhs67
21 months ago

#2 @swissspidy
20 months ago

  • Keywords close added

Since we were unable to reproduce this issue with the classic editor and you are using Elementor, I suggest reporting this to Elementor as it sounds like a bug on their end.

#3 @johnbillion
20 months ago

  • Milestone Awaiting Review deleted
  • Resolution set to invalid
  • Status changed from new to closed

Confirmed this appears to not be an issue in WordPress core. Thanks!

#4 @bhs67
20 months ago

  • Resolution invalid deleted
  • Status changed from closed to reopened

What is the link to contact Elementor? Thanks!

#5 @desrosj
20 months ago

  • Keywords reporter-feedback close removed
  • Resolution set to invalid
  • Status changed from reopened to closed

Their plugin support area is found here.

#6 @bhs67
20 months ago

  • Keywords reporter-feedback close added
  • Resolution invalid deleted
  • Status changed from closed to reopened

Now I remember. I did post at the Elementor github => https://github.com/elementor/elementor/issues/18053. Their response:

---
Unfortunately we can't fix this. Elementor Text Editor Widget uses the WordPress TinyMCE library for rich editing. We simply inherit the functionality. This should be fixed by fixed WordPress or by TinyMCE.
---

That is why I posted on this website. Is that comment correct, WordPress or TinyMCE? How do I contact support for TinyMCE? This is clearly a bug. Thanks!

#7 @jorbin
20 months ago

  • Keywords reporter-feedback close removed
  • Resolution set to invalid
  • Status changed from reopened to closed

TinyMCE has a contact us page at https://www.tiny.cloud/contact/

You are welcome to continue to comment while the ticket remains closed, but it is closed since this is not a bug in WordPress Core. Best of luck.

#8 @bhs67
20 months ago

The support agent at TinyMCE, says it is Elementor's problem. TinyMCE is unwilling to investigate.

Note: See TracTickets for help on using tickets.