Make WordPress Core

Opened 19 months ago

Closed 19 months ago

Last modified 19 months ago

#56298 closed defect (bug) (duplicate)

Pagination /0 and /0/0 on every WordPress Site

Reported by: webmarket79's profile webmarket79 Owned by:
Milestone: Priority: normal
Severity: normal Version: 6.1
Component: Canonical Keywords:
Focuses: Cc:

Description

Hi WordPress Team,

I discover some kind of bug with the pagination of WordPress.

You can reach every WordPress site with the ending /0.

Also on every site on the page, you can add a /0 and it will not return a 404 Error.

The problem is, also Google start indexing this pages and will handle it as duplicate content.

So in long term may WordPress Sites get ranked worse than the competition cms systems.

The is Code to switch of the pagination, but if you have a blog you will need the pagination.

May it needs some ReWrtite Rule for the /0, because this it will not needed.

/*Examples/
https://de.wordpress.org/about/
https://de.wordpress.org/about/0/

Kind regards

Pino

Change History (3)

#1 @tobifjellner
19 months ago

  • Component changed from Rewrite Rules to General
  • Keywords changes-requested removed
  • Resolution set to invalid
  • Severity changed from major to normal
  • Status changed from new to closed

Hi. Thanks for this useful report. I'm going to close this ticket as invalid since it's not about WordPress core, but about the wordpress.org site network. Those tickets belong in https://meta.trac.wordpress.org/
(Yeah, I'll be the first one to admit that it's not always obvius where to report some problem with WordPress :) )

Actually, a very similar problem was handled about 4 years ago, in https://meta.trac.wordpress.org/ticket/3944 so I'll reopen that ticket and link to this one.

#2 @TobiasBg
19 months ago

@tobifjellner: I believe that the wordpress.org links were only examples. It looks like this can be done on other sites as well.

#3 @SergeyBiryukov
19 months ago

  • Component changed from General to Canonical
  • Milestone Awaiting Review deleted
  • Resolution changed from invalid to duplicate

Hi there, welcome to WordPress Trac!

Thanks for the report, we're already tracking this issue in #53362.

Note: See TracTickets for help on using tickets.