Make WordPress Core

Opened 22 months ago

Closed 2 months ago

#56332 closed defect (bug) (worksforme)

Twenty Twenty-Two: H1-H4 font weight isn't rendered correctly if user's PC has Source Serif Pro installed

Reported by: zoonini's profile zoonini Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Bundled Theme Keywords: close
Focuses: Cc:

Description

Summary

On Windows marchines, the font weight on H1, H2, H2, and H4 blocks does not appear correctly if the user's PC already has the Source Serif Pro font installed (normal weight).

To replicate

  • Add Heading tags H1 through H4 on a page (note that H5 & H6 are not affected by this bug)
  • View the site on a Windows PC that has the Source Serif Pro font (Regular 400) installed

Result

The headings are too heavy.

Expected

The headings should be lighter than what appears in the browser, as they do on a Mac.

Compare

To compare, view the same page on a PC that does not have Source Serif Pro (Regular 400) installed. The headings appear lighter, the same as they do on a Mac.

Live Test Site

One of the issue's reporters created this test site to illustrate the issue:

https://zander-test.de/

Testing Conditions

Users report they've tested with:

Windows 10 (Firefox, Chrome, Opera)
Windows 11 (Firefox)

Related forum threads

https://wordpress.org/support/topic/font-weight-300-is-not-displayed/

https://wordpress.org/support/topic/heading-weight-default-font-showing-up-differently-on-windows

Attachments (2)

too-heavy.jpg (62.1 KB) - added by zoonini 22 months ago.
too heavy
correct-display.jpg (60.6 KB) - added by zoonini 22 months ago.
correct display

Download all attachments as: .zip

Change History (10)

@zoonini
22 months ago

too heavy

@zoonini
22 months ago

correct display

#1 @sabernhardt
22 months ago

Related: GB42190

#2 @elbsegler
22 months ago

Addendum from 08/13/2022:
The problem no longer exists in the current versions of the Chrome (104.0.5112.81), Opera (89.0.4447.91) and Edge (104.0.1293.54) browsers.
It persists with the Firefox browser (103.0.2).

#3 @elbsegler
21 months ago

With Firefox 104 the problem is solved.

#4 @zoonini
21 months ago

@elbsegler Thanks for the update. Are you still experiencing the issue in browsers other than Firefox? Could you please list the ones where you still see the issue, along with the browser version number? Thanks!

#5 @elbsegler
21 months ago

@zoonini
I tested it today with a Windows system.
Unfortunately, the error does exist in the Firefox browser. Sorry, my mistake.
Buggy in Firefox 104
Buggy in Firefox Developer 105

But correct in Chromium based browsers. See my entry above.
The problem no longer exists in the current versions of the Chrome (104.0.5112.81), Opera (89.0.4447.91) and Edge (104.0.1293.54) browsers.

#6 @sabernhardt
12 months ago

  • Keywords close added

I think this was fixed in GB42190 / #57430 for WordPress 6.2. Is that correct?

#7 @zoonini
12 months ago

Thanks, @sabernhardt

@elbsegler Are you still seeing this bug in WordPress 6.2?

#8 @karmatosed
2 months ago

  • Milestone Awaiting Review deleted
  • Resolution set to worksforme
  • Status changed from new to closed

I also believe this has been solved in WordPress 6.2 as do others on this ticket. With that in mind and it being marked for close 10 months ago, I am going to follow through on closing this ticket for now. We can absolutely reopen if more information comes to light. Should you be able to see this bug still @elbsegler please provide some steps and those can be explored specifically.

Thank you everyone for collaborating on this.

Note: See TracTickets for help on using tickets.