Make WordPress Core

#56510 closed enhancement (duplicate)

Verify permissions before update failed

Reported by: cartman34's profile Cartman34 Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Upgrade/Install Keywords:
Focuses: administration Cc:

Description

Hello,
I am using ACL to define permission on my wordpress folder, this is globally working fine, except when updating wordpress via web UI, the updates failed and I have to do it manually.
The error is

Warning: chmod(): Operation not permitted in /home/myuser/www/website/wp-admin/includes/class-wp-filesystem-direct.php on line 173

Then the installation is in invalid state.

So there is two improvements to prevent this case:

  • Verify all conditions & permissions before upgrading wordpress to find issues before starting to modify installation.
  • Handle ACL permissions.

Thank you for your consideration.

Change History (1)

#1 @costdev
20 months ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #56713.

Note: See TracTickets for help on using tickets.