Make WordPress Core

#56553 closed defect (bug) (reported-upstream)

Popover is positioned under the admin menu when not using full screen mode

Reported by: jonkastonka's profile jonkastonka Owned by:
Milestone: Priority: normal
Severity: normal Version: 5.9
Component: Editor Keywords: has-screenshots has-testing-info
Focuses: accessibility, administration Cc:

Description

When, for example, adding a link in Gutenberg, and not having full screen mode active, the popover is positioned under the admin menu.

Attachments (2)

image.png (316.1 KB) - added by jonkastonka 20 months ago.
Showing the problem
image_fix.png (220.7 KB) - added by jonkastonka 20 months ago.
Suggested fix UI

Download all attachments as: .zip

Change History (8)

@jonkastonka
20 months ago

Showing the problem

@jonkastonka
20 months ago

Suggested fix UI

#1 @krupalpanchal
20 months ago

  • Keywords has-screenshots added

This ticket was mentioned in Slack in #accessibility by joedolson. View the logs.


19 months ago

#3 @costdev
19 months ago

  • Keywords needs-patch has-testing-info added

Testing Instructions

These steps define how to reproduce the issue, and indicate the expected behavior.

Steps to Reproduce

  1. Navigate to Posts > Add New.
  2. Disable fullscreen mode from the ellipsis menu.
  3. Resize the screen to about 1200px width.
  4. Ensure that the admin menu is expanded (use the arrow icon at the bottom to expand it).
  5. 🐞 Insert some text, select it, and click to make it a link.

Expected Results

When testing a patch to validate it works as expected:

  • ✅ The link popover should not extend outside of its container.

When reproducing a bug:

  • ❌ The link popover should extend outside of its container.

Test Report Icons:
🐞 <= Indicates where issue ("bug") occurs.
✅ <= Behavior is expected.
❌ <= Behavior is NOT expected.

#4 @costdev
19 months ago

Reproduction Report

This report validates that the issue can be reproduced.

Environment

  • Server: Apache (Linux)
  • WordPress: 6.1-beta1-54282-src
  • Browser: Chrome 105.0.0.0
  • OS: Windows 10
  • Theme: Twenty Twenty-Two
  • Plugins: None activated

Actual Results

  • ✅ The link popover should extend outside of its container. Issue reproduced.
Version 0, edited 19 months ago by costdev (next)

This ticket was mentioned in Slack in #accessibility by ryokuhi. View the logs.


18 months ago

#6 @sabernhardt
18 months ago

  • Keywords needs-patch removed
  • Milestone Awaiting Review deleted
  • Resolution set to reported-upstream
  • Status changed from new to closed
  • Version changed from 6.0.2 to 5.9

Thanks for the report!

This seems to be the same issue as GB38723.

If you would like to add anything to the discussion, please comment there.

Note: See TracTickets for help on using tickets.