Make WordPress Core

Opened 8 years ago

Closed 7 years ago

#5659 closed enhancement (duplicate)

Please expose timezone offset through xmlrpc

Reported by: raghos Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: XML-RPC Keywords: needs-patch
Focuses: Cc:



I'm writing a client for wordpress. Right now, when one wants to submit a new post, there's no way to know what the timezone offset is, and must rely on the information provided by dateCreated and date_created_gmt from previous posts. This is not great in many situations.


Change History (5)

#1 @josephscott
8 years ago

  • Cc josephscott added
  • Component changed from General to XML-RPC
  • Keywords needs-patch added
  • Milestone changed from 2.6 to 2.5
  • Version set to 2.5

#2 @westi
8 years ago

Do the apis not just take ISO8601 timestamps?

I would expect the client to send either a UTC timestamp based on the clients timestamp or an ISO8601 timestamp with timezone offset and WordPress to use that to enter the info in the database?

#3 @josephscott
8 years ago

For new posts we use GMT, the problem is there isn't really a way to tell the client what the TZ offset value in the blog is set to.

I'm also working on a more generic interface to blog option values, which will include taking care of this issue as well.

#4 @ffemtcj
8 years ago

  • Milestone changed from 2.5 to 2.7

No Patch. Moved to 2.7

#5 @josephscott
7 years ago

  • Milestone 2.7 deleted
  • Resolution set to duplicate
  • Status changed from new to closed
  • Version 2.5 deleted

Exposing the time zone settings has been done in a more general way, taken care of in #7123.

Note: See TracTickets for help on using tickets.