WordPress.org

Make WordPress Core

Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#5660 closed enhancement (fixed)

Redesign of Plugins page

Reported by: DD32 Owned by: DD32
Milestone: 2.5 Priority: lowest
Severity: normal Version: 2.5
Component: Administration Keywords: has-patch
Focuses: Cc:

Description

First up, I'm not sure if theres any redesign for the admin plugin pages in the works or not, But even if there is, I thought i'd get this out there as an idea.

As i mentioned here: http://trac.wordpress.org/ticket/5625#comment:18 It'd be nice for the plugins page to have a single actions column, It should look a bit cleaner, and also allows more links/dynamic number of links to be presented in much the same way.
It would be a clean way to display the Uninstall link(#5625) as well (Screenshot includes a example of adding a 'Configure' link to the actions list)

I've attached a patch, And also a screenshot of the result, The CSS styling will probably need changing, but i'm mainly after input from devs on this. I'm happy for this ticket to remain on ice until after the admin redesign has been completely done, I just wanted to get this out there now.

Attachments (4)

example.png (7.9 KB) - added by DD32 6 years ago.
5660.diff (4.4 KB) - added by DD32 6 years ago.
plugins.tiff (215.7 KB) - added by ryan 6 years ago.
Manage Plugins Wireframe
5660.2.diff (3.8 KB) - added by DD32 6 years ago.
refresh the patch to allow a customised list of action links (refreshed again after [7515])

Download all attachments as: .zip

Change History (24)

DD326 years ago

DD326 years ago

comment:1 spencerp6 years ago

I like this idea. +1 from me.

comment:2 follow-up: darkdragon6 years ago

Hmm, I think I like the version in its own column after all.

I hope the devs like this idea as well. It would make adding configure link and uninstall a lot easier/cleaner.

comment:3 follow-up: darkdragon6 years ago

How did you get the configure link to show up? I'm not finding the code in the patch. It would be neat if the last column was nowrap.

comment:4 in reply to: ↑ 3 DD326 years ago

Replying to darkdragon:

How did you get the configure link to show up? I'm not finding the code in the patch. It would be neat if the last column was nowrap.

The column not wrapping would indeed be good.

As for the configure link, I simply used this code in a plugin file: (Mind you, A plugin would call a function to register such a link i would assume, and there'd be a check in the row loop to se if theres a configure link, or an uninstall link available for it)

add_filter('plugin_row_actions','pluginaction_filter');
function pluginaction_filter($actions){
	if( rand(1,3) == 1 ) //Only show it 1/3 of the time
		$actions[] = "<a href='#'>Configure</a>";
	return $actions;
}

comment:5 in reply to: ↑ 2 DD326 years ago

Replying to darkdragon:

Hmm, I think I like the version in its own column after all.

I'm still undecided on that as well honestly, The version number isn't something i care for, I dont need to see it all the time, But it doesnt look 'right' there either.

comment:6 follow-up: darkdragon6 years ago

It could be in the title attribute of the Plugin Name?

comment:7 darkdragon6 years ago

Or hidden by default but using JavaScript have the column with the version come up.

comment:8 in reply to: ↑ 6 DD326 years ago

Replying to darkdragon:

It could be in the title attribute of the Plugin Name?

Thats a possibility, But it also needs to be visible for a quick-look of what the current version is IMO.

Or hidden by default but using JavaScript have the column with the version come up.

Relying on Javascript for basic functionality seems a bad idea to me, But still a possibility.

I'm personally thinking re-instating the Version column, And trying to make the Action column behave nicer with the wrapping. I'm not that great with useable interfaces, So any suggestions are worth trying :)

Devs: Is the Green staying in the redesign? Is the table as we know it staying(aside from this ticket)?

I think i'll just not think about it too much until a dev can confirm if its worth going ahead with at the present time, I think a non-column-for-each-functionality layout is the way to go myself though - the original reason for this ticket.

comment:9 ryan6 years ago

I'll investigate what is planned for the plugins page.

comment:10 ryan6 years ago

The mockups do exactly what you have done, so I think we can go with this.

ryan6 years ago

Manage Plugins Wireframe

comment:11 follow-up: ryan6 years ago

Acutally, although a vertical bar is used a separator, the actions are still justified with each other across rows. See the attached tiff of the wireframe.

comment:12 ryan6 years ago

Let's retain the version column for now. If we need to retain colspan on the actions to get things to line up, we can do a count on the new actions array.

comment:13 in reply to: ↑ 11 DD326 years ago

Replying to ryan:

Acutally, although a vertical bar is used a separator, the actions are still justified with each other across rows. See the attached tiff of the wireframe.

Looking at that wireframe, it does look nice and slick, And the version column fits in nicely.

As for the actions, It seems they're just right justified to me, Which gives the column view.

Maybe 'Configure'(or any other actions) could be listed underneath Deactivate/Edit, As it seems the Delete button would be used for any uninstall methods.

comment:14 darkdragon6 years ago

  • Milestone changed from 2.5 to 2.6
  • Type changed from defect to enhancement

It doesn't seem that the plugins matches the new redesign. The plugins page has been cleaned up to match the new redesign, but hasn't added any of the new features.

I'm bumping this to 2.6, because I think this is a great idea and would like for it to get in soon.

comment:15 DD326 years ago

  • Keywords needs-patch added; dev-feedback 2nd-opinion has-patch removed

resetting to needs-patch, Ticket can be re-used for modifying plugin page in 2.6 to support more flexible functionality(dynamic columns/etc)

comment:16 DD326 years ago

Should be noted here that the Use of a single column + Pipes was introduced with this changeset:

(In [7066]) Style updates to plugins, export, and sidemenu from mt. fixes #6019

comment:17 DD326 years ago

  • Keywords has-patch added; needs-patch removed

attachment 5660.2.diff added.
refresh the patch to allow a customised list of action links

Allows a function to filter the list as such:

add_filter('plugin_action_links', 'plugins_configure');
function plugins_configure($actions){
	return array_merge(array('<a href="#">Configure</a>'), $actions);
}

which adds a Configure link to the start of the list, simpler to attach a link to the end of the list.

DD326 years ago

refresh the patch to allow a customised list of action links (refreshed again after [7515])

comment:18 ryan6 years ago

(In [7517]) Filter list of plugins actions. Props DD32. see #5660

comment:19 DD326 years ago

  • Milestone changed from 2.6 to 2.5
  • Resolution set to fixed
  • Status changed from new to closed

I'm going to call this Fixed, All the changes mentioned in the ticket have either been met by [7517] or [7066].

A Uninstall or Delete function will probably be in a new ticket anyway.

comment:20 DD326 years ago

Closed #4498 as a duplicate of this ticket.

I've also written up a plugin which showcases the ability to add a link to the start, or end of the plugin action list. It also shows activation/deactivation/validation of options.

http://dd32.id.au/files/wordpress/test-configure-link.php

Note: See TracTickets for help on using tickets.