Make WordPress Core

Opened 20 months ago

Closed 20 months ago

Last modified 13 months ago

#56614 closed defect (bug) (fixed)

I am getting 404 errors in multiple style.min.css

Reported by: nendeb55's profile nendeb55 Owned by: gziolo's profile gziolo
Milestone: 6.1 Priority: normal
Severity: normal Version: 6.1
Component: General Keywords:
Focuses: Cc:

Description

Failed to load resource: the server responded with a status of 404 (Not Found)

Here are just a few examples
/wp-includes/blocks/query-pagination-numbers/style.min.css?ver=6.1-alpha-54269
/wp-includes/blocks/query-pagination-next/style.min.css?ver=6.1-alpha-54269
/wp-includes/blocks/site-title/style.min.css?ver=6.1-alpha-54269
/wp-includes/blocks/navigation-submenu/style.min.css?ver=6.1-alpha-54269
/wp-includes/blocks/template-part/style.min.css?ver=6.1-alpha-54269
/wp-includes/blocks/column/style.min.css?ver=6.1-alpha-54269
/wp-includes/blocks/query-pagination-previous/style.min.css?ver=6.1-alpha-54269
/wp-includes/blocks/query/style.min.css?ver=6.1-alpha-54269
/wp-includes/blocks/query-pagination-previous/style.min.css?ver=6.1-alpha-54269

WordPress6.1-alpha-54269
Twenty Twenty-Two

Change History (4)

#1 @TobiasBg
20 months ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

This is caused by [54155], for #56408.
As that ticket is still open and the issue has been reported there, let's continue the discussion there.

#2 @gziolo
20 months ago

  • Owner set to gziolo
  • Resolution changed from duplicate to fixed

In 54323:

Blocks: Fix 404 error for core styles with no file

[54155] broke loading of style.css files, namely it was enqueuing style.css files that don't exist on the frontend, which lead to 404 HTTO errors. All these style.css files don't exist for core blocks as they should be registered style handlers without a file path.

Follow-up to [54155].
Props tobiasbg, nendeb55.
Fixes #56408, #56614.

#3 @nendeb55
20 months ago

Is it correct to use the following filters to cancel these functions?

add_filter( 'should_load_separate_core_block_assets', '__return_false' );

#4 @SergeyBiryukov
13 months ago

  • Milestone set to 6.1
Note: See TracTickets for help on using tickets.