Make WordPress Core

#56631 closed defect (bug) (fixed)

6.1 Beta 1: Pullquote to quote transform throwing an error

Reported by: ashleyleia's profile ashleyleia Owned by:
Milestone: 6.1 Priority: normal
Severity: normal Version: 6.1
Component: Editor Keywords: has-screenshots needs-patch
Focuses: Cc:

Description

Attempting to transform a Pullquote block to a quote block throws "TypeError: Found non-callable @@iterator" as soon as mouse hovers over "Quote" transform option.

This is my first Trac ticket, so bear with me...

Steps to reproduce:

  1. In the block editor, create a new Pullquote block.
  2. Click the Pullquote icon in the block toolbar.
  3. Hover over "Quote" in the list of transform options.

The error shown on the screen is:
"The editor has encountered an unexpected error."

The error in the browser console is:
react-dom.min.js?ver=17.0.1:9 TypeError: Found non-callable @@iterator

at C (block-editor.min.js?ver=ddd74f3bec6fb13282d1:26:32204)
at S (block-editor.min.js?ver=ddd74f3bec6fb13282d1:26:32264)
at block-editor.min.js?ver=ddd74f3bec6fb13282d1:26:36805
at block-editor.min.js?ver=ddd74f3bec6fb13282d1:26:37067
at e.type (block-editor.min.js?ver=ddd74f3bec6fb13282d1:26:37503)
at Object.blocks (block-editor.min.js?ver=ddd74f3bec6fb13282d1:26:37720)
at eval (eval at <anonymous> (data.min.js?ver=fd71fceb1a902c894958:2:2415), <anonymous>:3:29)
at Object.root (data.min.js?ver=fd71fceb1a902c894958:2:2503)
at eval (eval at <anonymous> (data.min.js?ver=fd71fceb1a902c894958:2:2415), <anonymous>:3:67)
at data.min.js?ver=fd71fceb1a902c894958:2:2503

This is on a clean install of version 6.1 Beta 1 with no active plugins, using Twenty-Twenty-Three theme and reproducible with Twenty-Twenty-Two.

Attachments (1)

Error.png (917.2 KB) - added by mukesh27 21 months ago.

Download all attachments as: .zip

Change History (8)

#1 @nithins53
21 months ago

Tested it and I can confirm this exists. Tested it on Edge and Chrome on windows.

#2 @mukesh27
21 months ago

  • Keywords has-screenshots added
  • Milestone changed from Awaiting Review to 6.1

Hi there! Welcome to core trac.

Thanks for the ticket. I also reproduce the bug in Mac system. Moving to 6.1 Milestone for visibility.

cc. @bernhard-reiter Editor leads

Last edited 21 months ago by mukesh27 (previous) (diff)

@mukesh27
21 months ago

#3 @mukesh27
21 months ago

  • Keywords needs-patch added

#4 @wildworks
21 months ago

This problem seems to be resolved in the latest Gutenberg.
I have left a comment in PR as I think it should be backported to WordPress 6.1.

Issue: Converting a Pullquote Block into a Quote Block causes Gutenberg to Crash
https://github.com/WordPress/gutenberg/issues/44307

PR: Pullquote: fix transform to quote crash
https://github.com/WordPress/gutenberg/pull/44315

#5 @nithins53
21 months ago

Tested this issue on the latest 6.1 beta 2 version and the issue is not there. Tested it with both Twenty Twenty-Two theme and Twenty Twenty-Three theme. Tested the issue on both Chrome and Edge on Windows 10.

#6 @ashleyleia
21 months ago

Also looks good on Safari and Chrome on MacOS using 6.1 Beta 2 with Twenty Twenty-Two and Twenty Twenty-Three.

#7 @audrasjb
21 months ago

  • Resolution set to fixed
  • Status changed from new to closed

Hello, thanks for opening this ticket.
As it looks like the issue was fixed in beta 2, let's close this as fixed.

Note: See TracTickets for help on using tickets.