Make WordPress Core

Opened 19 months ago

Closed 19 months ago

Last modified 19 months ago

#56653 closed task (blessed) (fixed)

Update Sodium Compat to 1.19.0

Reported by: jrf's profile jrf Owned by: sergeybiryukov's profile SergeyBiryukov
Milestone: 6.1 Priority: normal
Severity: normal Version: 6.1
Component: External Libraries Keywords: needs-patch php8 add-to-field-guide
Focuses: Cc:

Description

Sodium_Compat 1.19.0 has just been released and includes improved compatibility with the PHP 8.0 named parameters functionality.
While WP itself can not use this functionality yet, plugins can, so this is a welcome improvement.

The version included with WP should be updated.

Full details:

I've reviewed the diff and would recommend an update at the earliest convenience.

Previously: #48371, #51399, #51925, #53274, #53907, #55453, #56564, #56642

Related: #51553, #55327, #55650

Change History (2)

#1 @SergeyBiryukov
19 months ago

  • Owner set to SergeyBiryukov
  • Resolution set to fixed
  • Status changed from new to closed

In 54310:

Upgrade/Install: Update sodium_compat to v1.19.0.

The latest version of sodium_compat includes improved compatibility with the PHP 8.0 named parameters functionality.

Release notes:
https://github.com/paragonie/sodium_compat/releases/tag/v1.19.0

A full list of changes in this update can be found on GitHub:
https://github.com/paragonie/sodium_compat/compare/v1.18.0...v1.19.0

Follow-up to [49741], [51002], [51591], [52988], [54150].

Props jrf, paragoninitiativeenterprises.
Fixes #56653.

#2 @milana_cap
19 months ago

  • Keywords add-to-field-guide added
Note: See TracTickets for help on using tickets.