Make WordPress Core

Opened 21 months ago

Closed 19 months ago

Last modified 19 months ago

#56786 closed task (blessed) (fixed)

Replace branches 3.7 - 4.0 update notices

Reported by: peterwilsoncc's profile peterwilsoncc Owned by: peterwilsoncc's profile peterwilsoncc
Milestone: 6.2 Priority: normal
Severity: normal Version:
Component: Security Keywords: has-patch
Focuses: ui-copy Cc:

Description

Follow up to #56532.

The WordPress Security Team will cease providing updates for WordPress versions 3.7 – 4.0 as of December 1, 2022.

The new strings were added for translation preparation in #56532 and need to be implemented for display in WordPress versions 3.7 through 4.0

Attachments (5)

56532-37.diff (3.8 KB) - added by peterwilsoncc 21 months ago.
56532-38.diff (3.1 KB) - added by peterwilsoncc 21 months ago.
56532-39.diff (2.8 KB) - added by peterwilsoncc 21 months ago.
56532-40.diff (2.8 KB) - added by peterwilsoncc 21 months ago.
wp-eol-scripts.zip (4.9 KB) - added by peterwilsoncc 19 months ago.

Download all attachments as: .zip

Change History (32)

#5 @peterwilsoncc
19 months ago

In the linked pull requests:

  • Notification changes from the original patches
  • Version bumps
  • About page updates

For the about page, I've labeled the fixes as security releases. There are not any existing strings for "this is the final release of WordPress x.x" so the existing string labeling them as security fixes was chosen as a best fit.

@peterwilsoncc commented on PR #3683:


19 months ago
#6

Thanks @audrasjb, I've addressed this in each of the pull requests relating to this ticket.

Note: based on a quick search this is a new string (it's not even in trunk). My understanding is that this shouldn't be too big of a problem, but it would be a good idea to get it in to core.

@audrasjb commented on PR #3683:


19 months ago
#7

Thanks!
Yes, you're right, the string doesn't exist in core for now.
I see you opened ticket 57216 for this, I'll send a PR this morning :)

This ticket was mentioned in PR #3695 on WordPress/wordpress-develop by @peterwilsoncc.


19 months ago
#8

https://core.trac.wordpress.org/ticket/56786 version and about page bump targeting 3.7 branch

This ticket was mentioned in PR #3696 on WordPress/wordpress-develop by @peterwilsoncc.


19 months ago
#9

https://core.trac.wordpress.org/ticket/56786 version and about page bump targeting 3.8 branch

This ticket was mentioned in PR #3697 on WordPress/wordpress-develop by @peterwilsoncc.


19 months ago
#10

https://core.trac.wordpress.org/ticket/56786 version and about page bump targeting 3.9 branch

This ticket was mentioned in PR #3698 on WordPress/wordpress-develop by @peterwilsoncc.


19 months ago
#11

https://core.trac.wordpress.org/ticket/56786 version and about page bump targeting 4.0 branch

This ticket was mentioned in Slack in #core-committers by peterwilsoncc. View the logs.


19 months ago

#13 @peterwilsoncc
19 months ago

  • Milestone changed from Awaiting Review to 6.2

I've split the linked pull requests up in to two for each release: one to update the nag, the other for the version bump and about page update.

The new PRs contain code that @audrasjb approved earlier when they were bundled with the update nag notices.

wp-eol-scripts.zip contains the scripts I'll be running on the day.

#14 @audrasjb
19 months ago

Ok, it looks great to me, I approved the split PRs.
By the way, not sure the ticket milestone should be 6.2 🤔
Maybe rather WordPress.org? It doesn't make much more sense, but with this, it won't be attached to a 2023 release 🤷‍♂️

#15 @peterwilsoncc
19 months ago

  • Resolution set to fixed
  • Status changed from assigned to closed

In 54898:

Security: Replace update nag to indicate end of support.

Replace update nag in WordPress 4.0 to indicate users need to update to a newer version of WordPress in order to continue receiving security updates.

Props peterwilsoncc, audrasjb.
Fixes #56786 for the 4.0 branch.

#16 @peterwilsoncc
19 months ago

In 54899:

Security: Replace update nag to indicate end of support.

Replace update nag in WordPress 3.9 to indicate users need to update to a newer version of WordPress in order to continue receiving security updates.

Props peterwilsoncc, audrasjb.
Fixes #56786 for the 3.9 branch.

#17 @peterwilsoncc
19 months ago

In 54900:

Security: Replace update nag to indicate end of support.

Replace update nag in WordPress 3.8 to indicate users need to update to a newer version of WordPress in order to continue receiving security updates.

Props peterwilsoncc, audrasjb.
Fixes #56786 for the 3.8 branch.

#18 @peterwilsoncc
19 months ago

In 54901:

Security: Replace update nag to indicate end of support.

Replace update nag in WordPress 3.7 to indicate users need to update to a newer version of WordPress in order to continue receiving security updates.

Props peterwilsoncc, audrasjb.
Fixes #56786 for the 3.7 branch.

This ticket was mentioned in Slack in #core by peterwilsoncc. View the logs.


19 months ago

Note: See TracTickets for help on using tickets.