Make WordPress Core

Opened 14 years ago

Closed 14 years ago

Last modified 14 years ago

#5681 closed enhancement (duplicate)

Add comment-count to ATOM-feeds (RFC 4685)

Reported by: erunafailaro's profile Erunafailaro Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: General Keywords: atom, comment count, feed, rfc4685, filter
Focuses: Cc:

Description

I would like to suggest to adapt the ATOM-feed to be conform with RFC 4685 (http://www.ietf.org/rfc/rfc4685.txt).

This could be done by adding a new <link rel="replies">-tag within the loop of file /wp-includes/feed-atom.php together with an SQL-query for the comment count (see attached file).

As an alternative, this feature could be implemented as a plugin by using a filter, that only applies to the content of an atom-entry. Unfortunately, a wordpress-filter like "the_content_atom" is not yet available. This kind of filter would be highly appreciated, if modifying the core-file "feed-atom.php" is not possible.

Attachments (1)

feed-atom.php (2.5 KB) - added by Erunafailaro 14 years ago.
modified file /wp-includes/feed-atom-php

Download all attachments as: .zip

Change History (3)

@Erunafailaro
14 years ago

modified file /wp-includes/feed-atom-php

#1 @lloydbudd
14 years ago

  • Resolution set to duplicate
  • Status changed from new to closed

duplicate of #5434 ? Tested on trunk?

Please provide diffs not full files.

Marking as duplicate for now.

#2 @darkdragon
14 years ago

  • Milestone 2.6 deleted
Note: See TracTickets for help on using tickets.