Make WordPress Core

Opened 16 months ago

Closed 16 months ago

Last modified 16 months ago

#56934 closed task (blessed) (fixed)

Update `$_old_files` array for version 6.1

Reported by: davidbaumwald's profile davidbaumwald Owned by: davidbaumwald's profile davidbaumwald
Milestone: 6.1 Priority: high
Severity: normal Version: 6.2
Component: Upgrade/Install Keywords: has-patch commit dev-feedback fixed-major
Focuses: Cc:

Description

The $_old_files array needs to be updated for 6.1.

Running the check command from the Handbook in the Dry Run for 6.1 produced this:

$ svn diff --summarize https://core.svn.wordpress.org/tags/6.0 https://core.svn.wordpress.org/trunk | grep '^D'
D       https://core.svn.wordpress.org/tags/6.0/wp-content/themes/twentytwentyone/assets/sass/05-blocks/spacer/_style.scss
D       https://core.svn.wordpress.org/tags/6.0/wp-content/themes/twentytwentyone/assets/sass/05-blocks/spacer
D       https://core.svn.wordpress.org/tags/6.0/wp-includes/blocks/post-comments.php
D       https://core.svn.wordpress.org/tags/6.0/wp-includes/blocks/post-comments/style.css
D       https://core.svn.wordpress.org/tags/6.0/wp-includes/blocks/post-comments/style-rtl.min.css
D       https://core.svn.wordpress.org/tags/6.0/wp-includes/blocks/post-comments/style.min.css
D       https://core.svn.wordpress.org/tags/6.0/wp-includes/blocks/post-comments/editor-rtl.css
D       https://core.svn.wordpress.org/tags/6.0/wp-includes/blocks/post-comments/editor.css
D       https://core.svn.wordpress.org/tags/6.0/wp-includes/blocks/post-comments/editor-rtl.min.css
D       https://core.svn.wordpress.org/tags/6.0/wp-includes/blocks/post-comments/editor.min.css
D       https://core.svn.wordpress.org/tags/6.0/wp-includes/blocks/post-comments/block.json
D       https://core.svn.wordpress.org/tags/6.0/wp-includes/blocks/post-comments/style-rtl.css
D       https://core.svn.wordpress.org/tags/6.0/wp-includes/blocks/post-comments
D       https://core.svn.wordpress.org/tags/6.0/wp-includes/blocks/comments-query-loop/editor.css
D       https://core.svn.wordpress.org/tags/6.0/wp-includes/blocks/comments-query-loop/editor.min.css
D       https://core.svn.wordpress.org/tags/6.0/wp-includes/blocks/comments-query-loop/block.json
D       https://core.svn.wordpress.org/tags/6.0/wp-includes/blocks/comments-query-loop/editor-rtl.css
D       https://core.svn.wordpress.org/tags/6.0/wp-includes/blocks/comments-query-loop/editor-rtl.min.css

This seems to be accurate, but it should be confirmed.

The TT1 spacer block styles were removed in [54103].

Attachments (2)

56934.diff (1.3 KB) - added by davidbaumwald 16 months ago.
Patch
56934.2.diff (1.4 KB) - added by SergeyBiryukov 16 months ago.

Download all attachments as: .zip

Change History (10)

@davidbaumwald
16 months ago

Patch

#1 @SergeyBiryukov
16 months ago

  • Keywords has-patch added; needs-patch removed

Thanks for the ticket!

I get the same list, but I think the directories should also be included in the patch.

See 56934.2.diff, which also reorders the files alphabetically for consistency with previous entries.

#2 @davidbaumwald
16 months ago

  • Resolution set to fixed
  • Status changed from assigned to closed

In 54730:

Upgrade/Install: Update $_old_files for 6.1.

Props davidbaumwald, SergeyBiryukov.
Fixes #56934.

#3 @davidbaumwald
16 months ago

  • Keywords commit dev-feedback fixed-major added
  • Resolution fixed deleted
  • Status changed from closed to reopened

Reopening for backport to the 6.1 branch, pending a second committer's review.

#4 @desrosj
16 months ago

I'm wondering about including the deleted theme files here. Except 6.0, I don't see any additional wp-content/themes/* entries in the list.

As far as I know, themes are not included with update packages unless it's the first release being included (and they are not intentionally skipped with the CORE_UPGRADE_SKIP_NEW_BUNDLED constant).

The rest of [54730] looks good to me, though.

#5 follow-up: @desrosj
16 months ago

Updating from 6.0.3 to RC5, I get the following output:

Updating to version 6.1-RC5 (en_US)...
Downloading update from https://wordpress.org/wordpress-6.1-RC5.zip...
Unpacking the update...
Cleaning up files...
File removed: wp-includes/blocks/post-comments.php
File removed: wp-includes/blocks/post-comments/editor.min.css
File removed: wp-includes/blocks/post-comments/style-rtl.min.css
File removed: wp-includes/blocks/post-comments/block.json
File removed: wp-includes/blocks/post-comments/editor.css
File removed: wp-includes/blocks/post-comments/style.min.css
File removed: wp-includes/blocks/post-comments/editor-rtl.css
File removed: wp-includes/blocks/post-comments/editor-rtl.min.css
File removed: wp-includes/blocks/post-comments/style-rtl.css
File removed: wp-includes/blocks/post-comments/style.css
File removed: wp-includes/blocks/comments-query-loop/editor.min.css
File removed: wp-includes/blocks/comments-query-loop/block.json
File removed: wp-includes/blocks/comments-query-loop/editor.css
File removed: wp-includes/blocks/comments-query-loop/editor-rtl.css
File removed: wp-includes/blocks/comments-query-loop/editor-rtl.min.css
15 files cleaned up.
Success: WordPress updated successfully.

In my testing, it seems that files within wp-content/themes/* are not flagged during Core upgrades and can probably be left out from this list.

This ticket was mentioned in Slack in #core by desrosj. View the logs.


16 months ago

#7 @SergeyBiryukov
16 months ago

  • Resolution set to fixed
  • Status changed from reopened to closed

In 54737:

Upgrade/Install: Update $_old_files for 6.1.

Props davidbaumwald, SergeyBiryukov.
Reviewed by desrosj, SergeyBiryukov.
Merges [54730] to the 6.1 branch.
Fixes #56934.

#8 in reply to: ↑ 5 @SergeyBiryukov
16 months ago

Replying to desrosj:

In my testing, it seems that files within wp-content/themes/* are not flagged during Core upgrades and can probably be left out from this list.

Thanks! In that case, it looks like bundled theme files should be removed from the list and a note should be added to clarify that for future updates. I have created #56936 for that.

Note: See TracTickets for help on using tickets.