Make WordPress Core

Opened 20 months ago

Closed 20 months ago

Last modified 19 months ago

#56959 closed defect (bug) (duplicate)

Twenty Twenty-three table block padding is different for editor and frontend.

Reported by: nidhidhandhukiya's profile nidhidhandhukiya Owned by:
Milestone: Priority: normal
Severity: normal Version: 6.1
Component: Bundled Theme Keywords:
Focuses: css Cc:

Description

Steps to reproduce the issue:-

  1. Activate twenty twenty three theme.
  2. Choose table block.
  3. Now add some content on table and then check both the side.

You can able to see a difference of padding in editor and front end both sides.

I have attached video for better understanding.
Video URL :- https://share.cleanshot.com/D7W1f0RZaWjoH5qgrCSe

Change History (4)

#1 @nidhidhandhukiya
20 months ago

The reason behind this issue is in editor side we have the below css.

.wp-block-table td, .wp-block-table th {
    padding: 0.5em;
    border: 1px solid;
    word-break: normal;
}

If we remove this padding:0.5em and then check so the issue is resolved and the spacing looks the same.

#2 @mikachan
20 months ago

Thanks for reporting this!

I think this may be a duplicate of https://core.trac.wordpress.org/ticket/56818, which has a potential fix upstream in the editor: https://github.com/WordPress/gutenberg/pull/45069

#3 @mikachan
20 months ago

  • Resolution set to reported-upstream
  • Status changed from new to closed

#4 @desrosj
19 months ago

  • Milestone Awaiting Review deleted
  • Resolution changed from reported-upstream to duplicate

Duplicate of #56818.

Note: See TracTickets for help on using tickets.