Make WordPress Core

Opened 19 months ago

Closed 2 months ago

#57020 closed enhancement (wontfix)

Twenty Eleven: replace deprecated functions

Reported by: krunal265's profile krunal265 Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Bundled Theme Keywords: 2nd-opinion close
Focuses: Cc:

Description (last modified by sabernhardt)

Deprecated functions are used in the functions.php file of Twenty Eleven theme.
1) add_custom_background()
2) add_custom_image_header()

We need to use the add_theme_support() function instead of that.

Attachments (1)

57020.patch (730 bytes) - added by krunal265 19 months ago.
patch added.

Download all attachments as: .zip

Change History (5)

@krunal265
19 months ago

patch added.

#1 @krunal265
19 months ago

  • Component changed from General to Bundled Theme
  • Focuses performance coding-standards added
  • Severity changed from normal to major

#2 @sabernhardt
19 months ago

  • Description modified (diff)
  • Focuses performance coding-standards removed
  • Keywords 2nd-opinion added
  • Severity changed from major to normal
  • Summary changed from Twenty Eleven Theme: The deprecated function has been used in the twenty-eleven theme. to Twenty Eleven: replace deprecated functions

Hi and thanks for the report!

This is not a bug because the theme uses add_theme_support() for both custom-header and custom-background in twentyeleven_setup(). The deprecated functions were added in changeset:20983 to support WordPress versions before 3.4. Anyone who might still have a very old, unsupported version of WordPress likely will not update the theme either, but I think this is fine to keep in functions.php.

#3 @sabernhardt
11 months ago

  • Keywords close added
  • Type changed from defect (bug) to enhancement

#4 @karmatosed
2 months ago

  • Milestone Awaiting Review deleted
  • Resolution set to wontfix
  • Status changed from new to closed

I agree with the recommendation to close this. We can always reopen if anyone does want that. Thank you everyone for collaboration on this.

Note: See TracTickets for help on using tickets.