Make WordPress Core

Changes between Initial Version and Version 2 of Ticket #57020


Ignore:
Timestamp:
11/07/2022 11:09:33 PM (16 months ago)
Author:
sabernhardt
Comment:

Hi and thanks for the report!

This is not a bug because the theme uses add_theme_support() for both custom-header and custom-background in twentyeleven_setup(). The deprecated functions were added in changeset:20983 to support WordPress versions before 3.4. Anyone who might still have a very old, unsupported version of WordPress likely will not update the theme either, but I think this is fine to keep in functions.php.

Legend:

Unmodified
Added
Removed
Modified
  • Ticket #57020

    • Property Component changed from General to Bundled Theme
    • Property Summary changed from Twenty Eleven Theme: The deprecated function has been used in the twenty-eleven theme. to Twenty Eleven: replace deprecated functions
    • Property Keywords 2nd-opinion added
  • Ticket #57020 – Description

    initial v2  
    1 The deprecated function has been used in the functions.php file of twentyeleven theme.
    2 1) **add_custom_background()**
    3 2) **add_custom_image_header()**
     1Deprecated functions are used in the functions.php file of Twenty Eleven theme.
     21) `add_custom_background()`
     32) `add_custom_image_header()`
    44
    5 We need to use the add_theme_support() function instead of that.
     5We need to use the `add_theme_support()` function instead of that.