Make WordPress Core

Opened 18 months ago

Closed 15 months ago

Last modified 12 months ago

#57062 closed defect (bug) (duplicate)

show_in_menu causes error on adding post of CPT

Reported by: mahype's profile mahype Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Posts, Post Types Keywords:
Focuses: Cc:

Description

I have created a Custom Post Type and given a user the appropriate rights to manage this Custom Post Type. In addition, the user has only the same rights as a subscriber. This works so far. I can edit, save and create new posts.

But when I integrate the Post Type into another menu via show_in_menu, I can edit and save the Custom Post Type, but as soon as I want to create a new post, I get the error message "Sorry, you are not allowed to access this page.".

Change History (5)

#1 @johnbillion
18 months ago

  • Version 6.1 deleted

#2 @manfcarlo
15 months ago

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #22895.

#3 @manfcarlo
15 months ago

  • Resolution duplicate deleted
  • Status changed from closed to reopened

Sorry, upon reading closer, I think this is a duplicate of a different ticket.

#4 @manfcarlo
15 months ago

  • Resolution set to duplicate
  • Status changed from reopened to closed

Duplicate of #16808.

#5 @desrosj
12 months ago

  • Milestone Awaiting Review deleted
Note: See TracTickets for help on using tickets.