Make WordPress Core

Opened 19 months ago

Closed 4 months ago

#57084 closed defect (bug) (worksforme)

Admin User keeps seeing Site Language in Backend Plugins settings, even after changing and downloading other language

Reported by: eoinkennedy's profile eoinkennedy Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: I18N Keywords:
Focuses: administration Cc:

Description

Hi,

Scenario:
Site is in Language x, Admin User has Language y.
Need to show Backend Plugin settings in Language y for Admin User.

Steps:
Plugin settings in Backend are showing in Language x for Admin User (as expected).
Plugin translations only get downloaded for Language x (as expected).

Changing Site Language to y downloads Language files for Plugins (as expected).
Admin User can now see Language y in Backend settings (as expected).

Changing Site Language back to x leaves Language files for Plugins (as expected).
But Admin User again sees Language x in Backend settings again (not expected).

Verified for multiple Plugins that have 100% translations in Language y.

Thanks.

Attachments (8)

Change History (17)

#1 @sabernhardt
19 months ago

  • Component changed from Administration to I18N
  • Focuses administration added

Hi and thank you for the report!

I thought this might relate to #30559, but you said that the plugin translations downloaded.

  1. Go to the Updates screen and scroll to the bottom. Verify that there are no updates under the Translations heading (or click the button to update any available translations).
  2. Go to the admin user's Profile page. If you are in a different account, go to Users first and click the username (or the "Edit" link below it). Ensure that the Language is set to the user's preferred language instead of Site Default.
  3. Then check the plugin settings again.

#2 @sabernhardt
19 months ago

  • Component changed from I18N to Upgrade/Install

#3 @eoinkennedy
19 months ago

Checked as recommended. No change in Backend settings.

Please note, that I'm only using the displayed plugin as an example. All installed plugins behave the same way.

#4 @sabernhardt
19 months ago

Thanks for checking!

#5 @swissspidy
19 months ago

  • Component changed from Upgrade/Install to I18N

#6 @johnbillion
19 months ago

@eoinkennedy Is this a new bug in WordPress 6.1 or does it happen with older versions too? I have a suspicion this might be caused by [54682] but I need to test it fully.

#7 @eoinkennedy
19 months ago

Hi,

Happening with 6.03 as well, and has been there for some time for me, even going back to version 5.

Thanks,
Eoin

#8 @johnbillion
19 months ago

  • Version 6.1 deleted

#9 @swissspidy
4 months ago

  • Milestone Awaiting Review deleted
  • Resolution set to worksforme
  • Status changed from new to closed

Can't reproduce this, probably a plugin issue.

Note: See TracTickets for help on using tickets.