WordPress.org

Make WordPress Core

Opened 6 years ago

Closed 6 years ago

#5709 closed defect (bug) (fixed)

TinyMCE 3 Indent Button no longer does Blockquotes

Reported by: lloydbudd Owned by: azaozz
Milestone: 2.5 Priority: high
Severity: normal Version: 2.5
Component: TinyMCE Keywords: regression, needed-for-beta, has-patch
Focuses: Cc:

Description

TinyMCE 3 Indent Button no longer does Blockquotes

ENV: WP trunk r6641 (v2.5, 2.4-bleeding)

  • Regression from WP 2.3.x

Clicking the Indent Button results in <p style="padding-left: 30px;">


ADDITIONAL DETAILS

I suspect this was introduced with
[6632] TinyMCE 3.0 RC1. First cut, eexpect regressions. Props azaozz. see #5674

Minor: The button no longer has the hover label of "Indent list/blockquote (Alt+Shift+q)", though that should probably changed to just "Quote (Alt+Shift+q)" and there likely is a more appropriate icon that can can be used.

Attachments (1)

move-blockquote.patch (1.4 KB) - added by azaozz 6 years ago.

Download all attachments as: .zip

Change History (9)

comment:1 azaozz6 years ago

This is a change in TinyMCE 3. It works more like in a text editor (Word, Notepad, etc.) and you can nest the indents, it just increases the padding. There's also new "Blockquote" button that inserts the tag.

The label and keyboard shortcut will probably be added a bit later, when finalizing the integration of TinyMCE 3.0. We can also try to bind the "Tab" key to insert indent, although this may not work well with screen readers/accessibility mode.

comment:2 lloydbudd6 years ago

azaozz, thanks for this information. I don't know if WordPress's default button set should include both buttons then, but we definitely need the Quote one.

comment:3 lloydbudd6 years ago

  • Keywords needed-for-beta added
  • Priority changed from normal to high

Raising the priority of this issue, because resolution is needed before beta.

comment:4 follow-up: lloydbudd6 years ago

The blockquotes button in the Advanced row of buttons also has awkward behavior.

Clicking it at the start of paragraph, moves the cursor to the right margin.

Clicking the button will sometimes result in my whole article being blockquoted.

comment:5 in reply to: ↑ 4 ; follow-up: azaozz6 years ago

Replying to lloydbudd:

The blockquotes button in the Advanced row of buttons also has awkward behavior.

Clicking it at the start of paragraph, moves the cursor to the right margin.

Clicking the button will sometimes result in my whole article being blockquoted.

The new "Blockquote" button acts as a toggle: first click = insert blockquote tag, second click = close the tag (like the align buttons, the UL and OL, etc.). The closing of the tag should be after the paragraph. It also works if you finish the paragraph, then click on it and click the button.

We can switch the places of the "Blockquote" and the indent buttons if that will help. Or we can remove the indent/outdent altogether, but I think most people will like them, as they act exactly like the indent in word processors and can be nested (just the padding is increased).

comment:6 in reply to: ↑ 5 ; follow-up: lloydbudd6 years ago

Replying to azaozz:

The new "Blockquote" button acts as a toggle:

Yup, it just is (was?) buggy. Lets see how the .1 treats me and I will file tickets if I have repro steps for bad behavior.

We can switch the places of the "Blockquote" and the indent buttons if that will help.

Yes, please lets do that.

For WordPress the experience of the indent buttons are changing, whereas before it was nested blockquotes, so I feel it is essential to put the blockquote button on the front row, because bloggers quote more than they indent ;-)

Or we can remove the indent/outdent altogether, but I think most people will like them, as they act exactly like the indent in word processors and can be nested (just the padding is increased).

comment:7 in reply to: ↑ 6 azaozz6 years ago

  • Component changed from General to TinyMCE
  • Keywords has-patch added

Replying to lloydbudd:

Yup, it just is (was?) buggy. Lets see how the .1 treats me and I will file tickets if I have repro steps for bad behavior.

Yes, I see what you mean. For me it works best when the paragraph is finished, the next one is started and then clicking on the just finished paragraph and on "Blockquote".

azaozz6 years ago

comment:8 ryan6 years ago

  • Resolution set to fixed
  • Status changed from new to closed

(In [6973]) Move blockquote to first toolbar. Props azaozz. fixes #5709

Note: See TracTickets for help on using tickets.