Make WordPress Core

Opened 17 months ago

Closed 14 months ago

Last modified 14 months ago

#57102 closed defect (bug) (fixed)

Typo in MagpieRSS (deprecated)

Reported by: nithins53's profile nithins53 Owned by: audrasjb's profile audrasjb
Milestone: 6.2 Priority: lowest
Severity: trivial Version:
Component: Feeds Keywords: has-patch commit
Focuses: Cc:

Description

In wp-includes/rss.php, on line 198, 341 and 503 we can see typo errors.

Line 198- containging > containing

Line 341 descripton> description (typo in array key)

Line 503 habbit>habit

Change History (8)

This ticket was mentioned in PR #3617 on WordPress/wordpress-develop by @anantajitjg.


17 months ago
#1

  • Keywords has-patch added; needs-patch removed

#2 follow-up: @desrosj
17 months ago

  • Component changed from General to Feeds
  • Keywords commit added
  • Milestone changed from Awaiting Review to 6.2
  • Priority changed from normal to lowest
  • Severity changed from normal to trivial

The benefit of any updates to rss.php is becoming extremely low.

One thing to note is that changing the instance of $this->channel['descripton'] could result in unexpected behavior if someone using the class is checking for that index. While correcting the key's spelling would fix this bug, but would break those implementations.

Stepping back, I guess these are fine to make, but I'd honestly like to look at potentially being able to no-op this class entirely. MagpieRSS has been deprecated since WordPress 3.0, and a search of the plugin directory shows almost no real usage of the class (almost all of the matches are false positives or attempts to identify crawlers, which MagpieRSS is considered). I've opened #57107 to discuss this.

#3 in reply to: ↑ 2 @anantajitjg
17 months ago

Replying to desrosj:

The benefit of any updates to rss.php is becoming extremely low.

One thing to note is that changing the instance of $this->channel['descripton'] could result in unexpected behavior if someone using the class is checking for that index. While correcting the key's spelling would fix this bug, but would break those implementations.

Stepping back, I guess these are fine to make, but I'd honestly like to look at potentially being able to no-op this class entirely.

Completely agree with this. Looking forward to more updates from #57107.

#4 @johnbillion
17 months ago

  • Version 6.1 deleted

This ticket was mentioned in Slack in #core by costdev. View the logs.


14 months ago

#6 @audrasjb
14 months ago

  • Owner set to audrasjb
  • Status changed from new to accepted

Self assigning for commit.

#7 @audrasjb
14 months ago

  • Resolution set to fixed
  • Status changed from accepted to closed

In 55336:

Feeds: Fix various typos in MagpieRSS.

Props nithins53, desrosj, anantajitjg, mukesh27.
Fixes #57102.

Note: See TracTickets for help on using tickets.