Make WordPress Core

Opened 19 months ago

Closed 2 months ago

#57113 closed defect (bug) (worksforme)

Submenu's text are not visible in Home page Navigation in Twenty Twenty Two Theme

Reported by: shailu25's profile shailu25 Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Bundled Theme Keywords: has-screenshots has-patch needs-testing close
Focuses: ui, css Cc:

Description

  • Choose Twenty Twenty Two Theme
  • Activate theme
  • Add Menu items & submenu items
  • Check frontend side in home page (submenu item text are not visible)

Attachments (4)

attachment.png (44.2 KB) - added by shailu25 19 months ago.
Attachment
57113.diff (599 bytes) - added by itpathsolutions 19 months ago.
Patch added
57113.2.diff (660 bytes) - added by riccardodicurti 19 months ago.
Screenshot 2022-11-15 at 12.59.31.png (386.3 KB) - added by riccardodicurti 19 months ago.

Download all attachments as: .zip

Change History (14)

@shailu25
19 months ago

Attachment

@itpathsolutions
19 months ago

Patch added

#1 @itpathsolutions
19 months ago

  • Summary changed from Submenu's text are not visible in Home page Navigation to Submenu's text are not visible in Home page Navigation in Twenty Twenty Two Theme

#2 @itpathsolutions
19 months ago

  • Keywords has-patch added

#3 @riccardodicurti
19 months ago

I tested the 57113.diff patch and like in the screenshot the submenu items now are visible. I updated the patch to only add a comment.

#4 @riccardodicurti
19 months ago

  • Keywords needs-testing added

#5 @poena
19 months ago

  • Keywords close added

Hi!

@shailu25 Thank you for the report. Can you please confirm:

  • In Which version of WordPress and in which version of the theme did you find the bug?
  • What type of submenu is used?

I am asking because there are two types: One submenu for regular link items, and one for the pagelist block (the pages need to have child pages to show as a submenu).

This is a duplicate of https://core.trac.wordpress.org/ticket/55697, but this ticket was closed because the problem was believed to be fixed in WordPress in 6.1:
https://github.com/WordPress/gutenberg/pull/44578


I have tested the issue with WordPress 6.1.1 and theme version 1.3, using Chrome (Without Gutenberg active).

I am seeing two different results depending on the block type:
Link item submenu:
-In the editor, the submenu text is white on white background
-On the front, the submenu text is black on white background.
Pagelist submenu:
-In the editor, the submenu text is white on white background
-On the front, the submenu text is white on white background.

Because the problem is with the CSS that is provided by WordPress and not the theme,
the underlying issue needs to be fixed in Gutenberg and not by adding CSS to the theme.

This means that the next step is to close this issue, and either create a new issue in the Gutenberg GitHub repository, or reopen the old issue:
https://github.com/WordPress/gutenberg/issues/40908

#6 @shailu25
19 months ago

Hi @poena

I have tested the issue with WordPress 6.1.1 & 6.0 and theme version 1.3 but still getting submenu issue.

Submenu Type: one for the pagelist block (the pages need to have child pages to show as a submenu).

Reference Link: https://www.awesomescreenshot.com/video/12593297?key=102d103826a8c89af7b95c036c963730

Last edited 19 months ago by shailu25 (previous) (diff)

#7 @poena
19 months ago

Thank you for confirming.
It seems we also can not rule out that there is a problem when using a menu that is created with a classic theme (the menu in the theme test data).

#8 @shailu25
19 months ago

@poena

There is submenu issue with new setup. (without Theme Test Data)

Ref: https://www.awesomescreenshot.com/video/12594491?key=f2548fac6441b5d3fe2b0a9104abde5b

Version 0, edited 19 months ago by shailu25 (next)

#9 @poena
15 months ago

Retested today with WordPress 6.2-beta4-55461

Link item submenu:
-In the editor, the submenu text is black on white background
-On the front, the submenu text is black on white background.

Pagelist submenu:
-In the editor, the submenu text is black on white background
-On the front, the submenu text is black on white background.

#10 @karmatosed
2 months ago

  • Milestone Awaiting Review deleted
  • Resolution set to worksforme
  • Status changed from new to closed

I can confirm the same findings as @poena in testing. This leads me to support the recommendation to close. This doesn't mean we can't explore within the editor a solution or even reopen should testing come back with more information. Thank you everyone for collaboration on this.

Note: See TracTickets for help on using tickets.