Make WordPress Core

#57202 closed defect (bug) (duplicate)

Why do we load the default widget classes for all sites?

Reported by: pbearne's profile pbearne Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Widgets Keywords:
Focuses: Cc:

Description

Looking at wp_maybe_load_widgets(), we load all the default widget classes for every site

but in wp_widgets_add_menu we check for current_theme_supports( 'widgets' )

I belive we can save resources my moving the current_theme_supports( 'widgets' ) up into the wp_maybe_load_widgets() function

Change History (2)

#1 @pbearne
15 months ago

  • Summary changed from Why to we load the default widget classes for all sites? to Why do we load the default widget classes for all sites?

#2 @pbearne
15 months ago

  • Milestone Awaiting Review deleted
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #55595.

dup of https://core.trac.wordpress.org/ticket/55595
closing
can't fix

Note: See TracTickets for help on using tickets.