Make WordPress Core

Opened 18 months ago

Closed 5 months ago

#57311 closed defect (bug) (worksforme)

WP ENV installs latest xdebug without option to control the extension version

Reported by: udidol's profile udidol Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Build/Test Tools Keywords: close reporter-feedback
Focuses: Cc:

Description

This ticket is about WP ENV.
xDebug just released (Dec 8th 2022) v3.2.0.
In v3.2.0, xDebug drops support of PHP <=7.4.

wp-env, as part of its installation process, installs the latest xdebug (pecl install xdebug).

This breaks the wp-env build process on machines running PHP <=7.4.

Please add an option via the wp-env.json to control PHP Extension versions.

Change History (4)

#1 @costdev
18 months ago

  • Component changed from General to Build/Test Tools

#2 @johnbillion
18 months ago

  • Keywords needs-patch added
  • Type changed from feature request to defect (bug)

Thanks for the report @udidol !

#3 @desrosj
10 months ago

  • Keywords close reporter-feedback added; needs-patch removed

I'm not sure this is something we can fix here.

One clarification, the wp-env package is maintained over in the Gutenberg repository. The Docker setup for local WordPress development is found and maintained within this SVN repository.

The main difference, by default, is that wp-env uses the "official" (really unofficial) images that are maintained by the Docker team instead of the images that the WordPress team maintains. These are updated in the corresponding GitHub repository. However, it seems that they no longer release PHP 7.4 updates and only update images for the most recent version of WP.

I did look within wp-env, though, and it seems that you're right in saying that package is managing xDebug within the container, but there is a hard coded exception for PHP 7.x where only up to xdebug-3.1.6 is used. Using xDebug on PHP < 7.2 also explicitly returns an error.

It looks like this was suggested here and added in GB-50490, which roughly aligns with when this ticket was opened originally.

@udidol could you do some testing to see if that has been resolved for you? I was unable to reproduce with the latest version of wp-env.

Adding a suggestion to close as worksforme since I'm unable to reproduce.

#4 @hellofromTonya
5 months ago

  • Milestone Awaiting Review deleted
  • Resolution set to worksforme
  • Status changed from new to closed

As it's been 5 months with no additional feedback, I'll close the ticket.

@udidol are you still experiencing this issue? If yes, please review Jon's comment above. Were you able to do more testing? If yes, then please reopen and share your findings. Thank you.

Note: See TracTickets for help on using tickets.