Make WordPress Core

Opened 16 months ago

Closed 16 months ago

Last modified 16 months ago

#57327 closed enhancement (fixed)

Update "Your Site is Experiencing a Technical Issue" Email

Reported by: jb510's profile jb510 Owned by: sergeybiryukov's profile SergeyBiryukov
Milestone: 6.2 Priority: normal
Severity: minor Version: 5.2
Component: Site Health Keywords: has-patch commit
Focuses: ui-copy Cc:

Description

The current email sent by WordPress when a technical issue is detected is:

Howdy!

Since WordPress 5.2 there is a built-in feature that detects when a plugin or theme causes a fatal error on your site, and notifies you with this automated email.

In this case, WordPress caught an error with one of your plugin...

I think it's about time we stop calling out the WP version number when this feature was added. I find it confusing (and presumably other users do as well) when one's site is running the latest (6.1.1) to hear about something involving WP 5.2 when that doesn't add any helpful information.

Howdy!

WordPress has a built-in feature that detects when a plugin or theme causes a fatal error on your site, and notifies you with this automated email.

In this case, WordPress caught an error with one of your plugin...

Change History (10)

#1 @peterwilsoncc
16 months ago

  • Milestone changed from Awaiting Review to 6.2
  • Type changed from defect (bug) to enhancement

This change makes sense to me, I've moved it on to the 6.2 milestone.

#2 @johnbillion
16 months ago

  • Keywords needs-patch added

This ticket was mentioned in PR #3749 on WordPress/wordpress-develop by @NekoJonez.


16 months ago
#3

  • Keywords has-patch added; needs-patch removed

Ticket: https://core.trac.wordpress.org/ticket/57327

I have added an additional enter, since I find it strange that all the other placeholders have enters apart from ###cause###

@NekoJonez commented on PR #3749:


16 months ago
#4

Hi there, thanks for the PR!

Not including a line break for ###CAUSE### here is intentional, as the cause of the fatal error may not always be detected correctly and can just be an empty string if it's not in a plugin or theme.

When present, the string replacement does include a line break before and after, so the extra line break should be removed from here.

Fixed my man!

#5 follow-up: @kebbet
16 months ago

Possible duplicate of #54961 ?

#6 @kebbet
16 months ago

  • Focuses ui-copy added
  • Version set to 5.2

#7 in reply to: ↑ 5 @SergeyBiryukov
16 months ago

Replying to kebbet:

Possible duplicate of #54961 ?

Good catch, let's use this ticket to remove the WordPress 5.2 reference, and #54961 for any further edits.

#8 @mukesh27
16 months ago

  • Keywords commit added
  • Owner set to SergeyBiryukov
  • Status changed from new to assigned

Thanks @NekoJonez for the PR.

@SergeyBiryukov PR is now ready for second review.

Adding commit for final review and commit consideration.

#9 @SergeyBiryukov
16 months ago

  • Resolution set to fixed
  • Status changed from assigned to closed

In 55001:

Site Health: Remove the WordPress 5.2 reference from the email sent on fatal errors.

The version reference was initially added to reduce confusion and make it clear that this is new WordPress functionality, with the website itself sending an automated notification of a fatal error, most likely in a plugin or theme.

Almost four years and several major releases later, it no longer adds any helpful information and can be removed.

Follow-up to [44973], [45181], [45268].

Props NekoJonez, jb510, peterwilsoncc, kebbet, mukesh27, mrwweb, johnbillion, SergeyBiryukov.
Fixes #57327. See #54961.

@SergeyBiryukov commented on PR #3749:


16 months ago
#10

Thanks for the PR! Merged in 55001.

Note: See TracTickets for help on using tickets.