Make WordPress Core

Opened 16 months ago

Closed 3 weeks ago

#57355 closed defect (bug) (worksforme)

Twenty Twenty-Three Theme bug: marking text in backend is black

Reported by: nmschaller's profile nmschaller Owned by:
Milestone: Priority: normal
Severity: normal Version: 6.1
Component: Bundled Theme Keywords: reporter-feedback close
Focuses: ui Cc:

Description (last modified by poena)

Wordpress.com
Twenty Twenty-Three theme
Electric Design with change: color 2 blue >> black

In the Gutenberg editor or Site Editor:
BUG: when I mark text, the marking is black. As the text is also black, it is not possible to see the marked text. This has been in another color in the previous theme (Twenty Twenty-Two).

Change History (4)

#1 @audrasjb
16 months ago

  • Component changed from Themes to Bundled Theme
  • Keywords reporter-feedback added; needs-design removed
  • Version changed from 6.1.1 to 6.1

Hello @nmschaller and thank you for reporting this,

Could you please clarify how this can be reproduced? Are you using a specific text formatting button to "mark" the text? Or are you just using a <mark> HTML tag?

Some screenshot may also help to understand/reproduce the issue :)

Thanks!

#2 @poena
14 months ago

  • Description modified (diff)

It would be helpful to have more testing instructions. I have tested it to the best of my ability.

I was not able to reproduce that the highlight color changes when one switches from Twenty Twenty-Two to Twenty Twenty-Three. This is because the color code for the highlight is inline. It does not change when you switch themes:

<p><mark style="background-color:#ffffff" class="has-inline-color">Highlighted text</mark></p>

Reproduction Report

This report validates that the issue can not be reproduced without the user manually changing colors.

Environment

  • OS: macOS 12.2.1
  • Web Server: Nginx
  • PHP: 8.1.9
  • WordPress: 6.2-beta4-55461
  • Browser:Chrome
  • Theme: Twenty Twenty-Three
  • Active Plugins:
    • WordPress Beta Tester 3.2.9

Test 1

Activate Twenty Twenty-Three
Open the Site Editor, Styles, Browse Styles
Select the Electric style variation
Open the theme color palette. Change the second color, the blue, to black.
Save.

Select or add a new text block, for example a heading or paragraph.
Select the text. Note the color. In my test, the default highlight color for selected text is a light blue grey.

With the text selected, open the Highlight option in the Options menu in the block toolbar.
Here, the user is able to change the background color and text color of the highlight.
In that case, the colors are changed due to a user decision, and the user has the option to adjust the colors to correct them. Therefor, I don't believe this is a bug.

Test 2

Activate Twenty Twenty-Two.
Create a new post.
Add a text block, for example a paragraph.
Select the text in the block and open the Highlight option from the Options menu in the toolbar.
Select the second palette color as the highlight background. I choose this color since it is the one mentioned by the reporter.
Save.

Switch themes to Twenty Twenty-Three.
Open the post you just created, and confirm that the highlight background color is still white.
Next please follow the instructions of test 1 to select the Electric style variation and change the blue palette color to black.
Confirm that the highlight background color in the post is still white.

Actual Results

  • Issue can not be reproduced without the user manually changing colors.

#3 @karmatosed
4 weeks ago

  • Keywords close added

I also find myself unable to reproduce. For now, I am going to add the keyword 'close' as this has waited for further instructions, if we do get them though we can always remove that and progress to see if we can recreate.

Thank you everyone for collaborating so far.

#4 @karmatosed
3 weeks ago

  • Milestone Awaiting Review deleted
  • Resolution set to worksforme
  • Status changed from new to closed

I am going to close this now as it has had some time for feedback, thank you everyone.

Note: See TracTickets for help on using tickets.