Make WordPress Core

Opened 16 months ago

Closed 12 days ago

#57433 closed enhancement (wontfix)

Twenty Twenty-One: Pagination issue

Reported by: patelhitesh's profile patelhitesh Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Bundled Theme Keywords: has-screenshots close
Focuses: css Cc:

Description

In the Twenty Twenty-One theme, when we inspect the page set the width 768px then pagination links are not displayed.

Steps to reproduce:
Activate the Twenty Twenty-One theme
Inspect the page and set the width to 768px
The pagination links are not displayed

Attachments (2)

CleanShot 2023-01-09 at 15.06.13@2x.png (140.4 KB) - added by patelhitesh 16 months ago.
Pagination issue in the Twenty Twenty-One theme
57433.patch (486 bytes) - added by patelhitesh 16 months ago.
Coding files for pagination issue

Download all attachments as: .zip

Change History (8)

@patelhitesh
16 months ago

Pagination issue in the Twenty Twenty-One theme

#1 @audrasjb
16 months ago

  • Component changed from Themes to Bundled Theme
  • Focuses javascript removed
  • Keywords needs-patch needs-design-feedback removed

Hello @patelhitesh, welcome to Trac and thank you for this ticket,

Here is the generated CSS rule causing this behavior:

@media only screen and (max-width: 821px) {
    .pagination .page-numbers, .comments-pagination .page-numbers {
        display: none;
    }
}

This is the expected behavior: pagination links take a lot of room on small screens, and are not strictly necessary since the links to previous and next posts are still displayed.

#2 @patelhitesh
16 months ago

Hello @audrasjb

Thank you for your message.

I understand that pagination links take a lot of room to display page links but we can expect at least a 768px layout.

@patelhitesh
16 months ago

Coding files for pagination issue

#3 @audrasjb
16 months ago

I’m not sure it’s a good thing to introduce a new breakpoint at 768px for a specific element when the intermediate breakpoint is 822px (and 482px for small screens) everywhere else in the stylesheet.

#4 @SergeyBiryukov
13 months ago

  • Summary changed from Pagination issue in Twenty Twenty-One theme to Twenty Twenty-One: Pagination issue

#5 @karmatosed
2 weeks ago

  • Keywords close added

My recommendation is to close this as I agree with @audrasjb that I don't think it is a good idea to introduce a new breakpoint. With that in mind, I am going to add the keyword 'close' - this doesn't stop discussion if it is needed. Thank you everyone for the collaboration so far.

#6 @karmatosed
12 days ago

  • Milestone Awaiting Review deleted
  • Resolution set to wontfix
  • Status changed from new to closed

Thank you everyone I am going to close this now.

Note: See TracTickets for help on using tickets.