WordPress.org

Make WordPress Core

Opened 6 years ago

Closed 5 years ago

Last modified 5 years ago

#5747 closed defect (bug) (fixed)

Cannot select text in text widget

Reported by: nullbarriere Owned by:
Milestone: 2.8 Priority: normal
Severity: normal Version: 2.3
Component: Widgets Keywords:
Focuses: Cc:

Description

By reporting this I refer to Wordpress Forum http://wordpress.org/support/topic/139464?replies=18

In short: In (some versions of?) IE6 and/or IE7 the INPUT and TEXTAREA fields of widgets accepting text input in the options dialog (first but not only the text widget) do not allow text selecting/highlghting.

My Solution as posted and worked with for while now:

I looked into the topic a little deeper. Theres a bug with jQuery Dragging. The Options Dialog of widget is draggable (reasons for that are not obvious to me). Since IE is highlighting text of layers under a dragged div, jQuery intentionally disables highlighting while dragging divs. Well, I looked into it just a little deeper, so I dont know yet how to really fix this keeping the draggability of the dialog, but for a workaround I came up with the idea of just disabling the (unneeded?) draggability:

in wp-admin/widgets.php commented out the line
jQuery('#<?php echo $widgetid?; ?>control').Draggable({handle: '.controlhandle', zIndex: 1000});

Change History (14)

comment:1 DD326 years ago

  • Version set to 2.3

Is this still applicable to current release? Or can this be closed off?

comment:2 thee176 years ago

  • Resolution set to wontfix
  • Status changed from new to closed

comment:3 thee176 years ago

  • Milestone 2.3.4 deleted

comment:4 Denis-de-Bernardy5 years ago

  • Milestone set to 2.8
  • Resolution wontfix deleted
  • Status changed from closed to reopened

Still current based on the customers who reported this. See #6470 for other IE-related issues.

comment:5 Denis-de-Bernardy5 years ago

  • Component changed from General to Widgets

comment:6 Denis-de-Bernardy5 years ago

Here's a report from one of them:

Problem exists using WP 2.7, default theme and no plugins active with IE7.

  • You cannot select text in a text widget. Newsletter widget is also the same so it is not just the text widget itself. (1)
  • Adding a text widget, the clicking edit causing widget to disappear. (that would be #6470)

I had vaguely understood a widget UI overhaul was slated in WP 2.8. Was that postponed?

(1) this one has a textarea, much like the text widget.

comment:8 janeforshort5 years ago

  • Milestone changed from 2.8 to Future Release

Punting due to feature freeze. Reconsider with next release.

comment:9 Denis-de-Bernardy5 years ago

  • Milestone changed from Future Release to 2.8

might be fixed in the new interface

comment:10 Denis-de-Bernardy5 years ago

  • Keywords needs-testing added

comment:11 Denis-de-Bernardy5 years ago

  • Keywords needs-patch added

comment:12 hakre5 years ago

test with ie 6. no longer reproduceable, works in 2.8 trunk. all this has changed a lot since 2.3 so I suggest to close this as worksforme. will add an additional ie7 test with the other computer in a minute.

comment:13 hakre5 years ago

  • Keywords needs-patch needs-testing removed
  • Resolution set to fixed
  • Status changed from reopened to closed

As expected, ie 7 worksforme as well. i will close the issue now. feel free to reopen when you experience these problems with 2.8 / 2.8 trunk again.

comment:14 azaozz5 years ago

This was (hopefully) fixed by changing the sortable container from <li> to <div> on the admin page. It seems it's a long standing bug in ui.sortable.

Note: See TracTickets for help on using tickets.