Make WordPress Core

Opened 16 months ago

Closed 16 months ago

Last modified 15 months ago

#57559 closed enhancement (fixed)

Adds shadow presets support in theme.json

Reported by: mamaduka's profile Mamaduka Owned by: hellofromtonya's profile hellofromTonya
Milestone: 6.2 Priority: normal
Severity: normal Version:
Component: Themes Keywords: gutenberg-merge has-patch has-unit-tests commit
Focuses: Cc:

Description

Adds shadow presets support via theme.json file for block and hybrid themes.

Covers following PRs:

Change History (10)

@Mamaduka commented on PR #3915:


16 months ago
#2

I just pushed the theme.json update for shadow presets. Based on the diff, this is the only change since WP 6.1, so I won't create a separate PR.

Cc @oandregal

@oandregal commented on PR #3915:


16 months ago
#3

I just pushed the theme.json update for shadow presets. Based on the diff, this is the only change since WP 6.1, so I won't create a separate PR.

:+1: Good call, those changes pertain to this feature as well.

@hellofromTonya commented on PR #3915:


16 months ago
#4

Current reviewing. There are a few tweaks needed to the tests. And there's a merge conflict.

#5 @hellofromTonya
16 months ago

  • Owner set to hellofromTonya
  • Status changed from new to reviewing

Self-assigning for review and commit.

@hellofromTonya commented on PR #3915:


16 months ago
#6

Rebase this PR on top of wordpress-develop current trunk branch to resolve the merge conflict. Force pushed.

#7 @hellofromTonya
16 months ago

  • Keywords commit added
  • Summary changed from Sync shadow presets support in theme.json to Adds shadow presets support in theme.json

PR 3915 is ready for commit.

  • Confirmed both GB PRs are present in this PR ✅
  • Changes are noted in @since 6.2.0
  • Includes tests ✅
  • Has a test report ✅

#8 @hellofromTonya
16 months ago

  • Resolution set to fixed
  • Status changed from reviewing to closed

In 55176:

Themes: Add shadow presets support for theme.json.

Adds shadow presets support for theme.json within the WP_Theme_JSON by

  • Adding it to presets metadata and valid settings.
  • Defining the default shadow presets in Core's theme.json.

Includes PHPUnit tests.

References:

Follow-up to [54162], [52049], [50973].

Props madhudollu, mamaduka, oandregal, scruffian, hellofromTonya.
Fixes #57559.

#10 @hellofromTonya
15 months ago

In 55405:

Themes: Add 3 and update 2 shadow presets in theme.json.

Adds Deep, Outlined, and Crisp default shadow presets to Core's theme.json file.

Updates the Natural and Sharp 'shadow' styles.

These shadow presets are used to populate the Shadow tools in the Site Editor's Global Styles UI.

References:

Follow-up to [55176].

Props franz00, madhudollu, ajlende, beafialho, costdev, dhrupo, fabiankaegy, hellofromTonya, jameskoster, joen, kellychoffman, mamaduka, mtias, oandregal, priethor, richtabor, scruffian.
Fixes #57708.
See #57559.

Note: See TracTickets for help on using tickets.