Make WordPress Core

Opened 13 months ago

Closed 13 months ago

Last modified 7 months ago

#57570 closed enhancement (duplicate)

WP_Text_Diff_Renderer_Table should be compatible with PHP 8.2

Reported by: antonvlasenko's profile antonvlasenko Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: General Keywords:
Focuses: Cc:

Description

As WP_Text_Diff_Renderer_Table has magic methods like __set and __get, it should be checked to verify that it's compatible with PHP 8.2.
PHP 8.2 deprecates dynamic class properties.

Change History (4)

#1 @antonvlasenko
13 months ago

I'm working on a patch for this issue.

#2 @antonvlasenko
13 months ago

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #56876.

Closed in favor of https://core.trac.wordpress.org/ticket/56876.
This is not exactly a duplicate, but keeping all related fixes in a single ticket makes sense.

#3 @desrosj
7 months ago

  • Keywords dev-feedback removed
  • Milestone Awaiting Review deleted

#4 @desrosj
7 months ago

  • Component changed from Users to General
Note: See TracTickets for help on using tickets.