Make WordPress Core

Opened 14 months ago

Last modified 13 months ago

#57672 new enhancement

Help: only repo plugins and such can be updated on the help page?

Reported by: nekojonez's profile NekoJonez Owned by:
Milestone: Awaiting Review Priority: normal
Severity: minor Version:
Component: Help/About Keywords: 2nd-opinion has-patch
Focuses: ui, administration Cc:

Description

If you look at this string: https://translate.wordpress.org/projects/wp/dev/admin/nl-be/default/?filters%5Bstatus%5D=either&filters%5Boriginal_id%5D=76683&filters%5Btranslation_id%5D=99106010

if you read it literally, it looks like you can only get auto updates from items from the repo here on wp.org.
Yet, there are premium plugins and theme's which can do this as well.
Is this something were we should change the phrasing of this?

Change History (4)

#1 @costdev
14 months ago

  • Keywords 2nd-opinion added

Thanks for opening this ticket @NekoJonez!

It might be worth just removing the mention of WordPress.org repositories:

On this screen, you can update to the latest version of WordPress, as well as update your themes, plugins, and translations.

Adding 2nd-opinion to help get this ticket some attention.

This ticket was mentioned in PR #4042 on WordPress/wordpress-develop by @NekoJonez.


14 months ago
#2

  • Keywords has-patch added

Since you can also update premium themes & plugins... It's a bit misleading in a way if it says that, that page only updates from the WP.org repo.

Trac ticket: [](https://core.trac.wordpress.org/ticket/57672)

#3 @NekoJonez
14 months ago

I just created a PR to show how I think it looks after @costdev suggestion, which I totally agree with.

#4 @oglekler
13 months ago

We have this text in Help on the WordPress Updates page, when on Plugins page with have:
"Auto-updates are only available for plugins recognized by WordPress.org, or that include a compatible update system."

I wonder if this phrase should be like this:
"On this screen, you can update to the latest version of WordPress, as well as update your themes, plugins, and translations from the WordPress.org repositories or a compatible update system."

Note: See TracTickets for help on using tickets.