Make WordPress Core

Opened 16 months ago

Last modified 16 months ago

#57693 new defect (bug)

Browser is not recognizing font from WordPress export

Reported by: jthomas2's profile jthomas2 Owned by:
Milestone: Awaiting Review Priority: normal
Severity: major Version:
Component: Plugins Keywords: reporter-feedback
Focuses: css Cc:

Description

I've used the 'Simple Static, plugin to export my site out as an HTML file, solely because that was the request of the client. The plugin also exports CSS fils, js, theme, pretty much everything needed for it to look the way I built it in WordPress.

Now, when I export and test on my computer everything loads correctly (I've tried 3 different browsers). But for the client, the site won't load the correct font. I've even gone into the exported file and styled each individual instance where the font is used. Didn't think I would have to do that because it's a universal font.

Has anybody run into a situation similar, and how did you work around it.

Change History (1)

#1 @sabernhardt
16 months ago

  • Keywords reporter-feedback added
  • Summary changed from Browser is not recognizing font fro WordPress export to Browser is not recognizing font from WordPress export

Thanks for the report!

Could you share which theme you use (or the stylesheet link) and which version of WordPress you have?

I know block themes can have the wrong weight or style of a font if the visitor has another variant installed on their device (GB42190 / #57430). Also, you likely are not testing WordPress 6.2 beta, but I would like to know if you found a problem with one of the older bundled Twenty * themes.

Otherwise, this might be more appropriate on the plugin's support forum. If you meant Simply Static, their forum is on WordPress.org.

Note: See TracTickets for help on using tickets.