Make WordPress Core

#57695 closed enhancement (wontfix)

Third-party URLs should be open in a new tab

Reported by: rajeshraval786's profile rajeshraval786 Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Administration Keywords: has-patch close
Focuses: accessibility, administration Cc:

Description

I cross-checked admin for each section and try to open all third-party links in a new tab by default.

Attachments (1)

57695.patch (52.2 KB) - added by rajeshraval786 16 months ago.
This patch file includes all files which have third party information urls.

Download all attachments as: .zip

Change History (6)

@rajeshraval786
16 months ago

This patch file includes all files which have third party information urls.

#1 @costdev
16 months ago

  • Keywords dev-feedback added
  • Severity changed from major to normal
  • Version trunk deleted

Hi @rajeshraval786, thanks for opening this ticket!

Please see #23432, which has an ongoing discussion about when links should open in new tabs, and how to indicate this to all users.

Pinging @joedolson @afercia, if available, for their thoughts on whether this ticket should be kept open, or whether it should be closed as a duplicate of #23432, or another resolution.

#2 @rajeshraval786
16 months ago

Okay @costdev ,

Thanks for letting me know 👍

#3 @audrasjb
16 months ago

  • Keywords close added; dev-feedback removed

Hello @rajeshraval786 and thanks for the ticket,

Forcing links to open in a new tab should only happen in very specific and rare use cases, like when the user is currently filling a form or accomplishing a complex task. In other cases, WordPress should not force links to open in a new tab.

The proposed patch adds target blank attribute to all external links, so I'd say this is a candidate for closing as wontfix. See #23432 for more detailed info about the best practices in terms of accessibility :)

Last edited 16 months ago by audrasjb (previous) (diff)

#4 @rajeshraval786
16 months ago

Okay, @audrasjb

No problem, I see the issue and I tried to resolve it that's why I generated a patch file by adding targets on files where necessary.

Thanks.

#5 @audrasjb
16 months ago

  • Milestone Awaiting Review deleted
  • Resolution set to wontfix
  • Status changed from new to closed

Thanks for adding more context @rajeshraval786 :)
Closing this as wontfix as per previous comments.

Note: See TracTickets for help on using tickets.