Make WordPress Core

Opened 17 months ago

Closed 17 months ago

Last modified 17 months ago

#57708 closed defect (bug) (fixed)

Site Editor: Global Style Button block Shadow presets is empty

Reported by: franz00's profile franz00 Owned by: hellofromtonya's profile hellofromTonya
Milestone: 6.2 Priority: normal
Severity: normal Version: 6.2
Component: Editor Keywords: has-screenshots has-patch gutenberg-merge has-testing-info commit
Focuses: Cc:

Description

Shadow presets window is empty when trying to apply the presets for Button block in the Global Style.

Testing environment:
WP 6.2 beta 1, Firefox Dev Ed. 110.0b9, Chrome 110.0.5481.78, Windows 11, TT3 & Powder themes.

GIF image https://imgur.com/a/gDh828C

Steps to reproduce:

  1. Activate a block theme (TT3 or other)
  2. Click Global Styles
  3. Select Button block to customize
  4. Choose Shadow property
  5. Observe the Shadow presets window is empty

Attachments (2)

trac57708-before.gif (1.4 MB) - added by hellofromTonya 17 months ago.
Test Report: can reproduce the issue (before the patch is applied)
trac57708-after.gif (913.4 KB) - added by hellofromTonya 17 months ago.
Test Report: PR 4114 resolves the issue

Change History (17)

#1 @franz00
17 months ago

  • Summary changed from Global Style Shadow presets window is empty to Site Editor: Global Style Button block Shadow presets is empty

#2 @costdev
17 months ago

  • Milestone changed from Awaiting Review to 6.2

Thanks @franz00! Moving to the 6.2 milestone for visibility and decision about whether to use this ticket as a tracking ticket for a possible backport from GB.

#3 @dhrupo
17 months ago

@costdev I have checked gutendev and found no issues there. But the issue still remains on wordpress-develop side. Thanks

#4 @costdev
17 months ago

Thanks @dhrupo! Yes it appears something was not merged to wordpress-develop as noted in this comment.

@ndiego Do you want to use this ticket to for tracking the merge, or handle this separately?

#5 @Mamaduka
17 months ago

It looks like I missed some recent changes when syncing the theme.json file to the core.

I will create a new patch to include everything for shadow presets.

This ticket was mentioned in PR #4114 on WordPress/wordpress-develop by @Mamaduka.


17 months ago
#6

  • Keywords has-patch added

PR sync core shadow presets from the Gutenberg plugin. This should also fix shadow presets being empty in 6.2 beta3.

Trac ticket: https://core.trac.wordpress.org/ticket/57708

@Mamaduka commented on PR #4114:


17 months ago
#7

The failing E2E tests seem unrelated to the changes in this PR.

#9 @hellofromTonya
17 months ago

  • Keywords gutenberg-merge added
  • Owner set to hellofromTonya
  • Status changed from new to reviewing

@hellofromTonya
17 months ago

Test Report: can reproduce the issue (before the patch is applied)

@hellofromTonya
17 months ago

Test Report: PR 4114 resolves the issue

#10 @hellofromTonya
17 months ago

  • Keywords has-testing-info added
  • Version set to trunk

Testing Instructions

These steps define how to reproduce the issue, and indicate the expected behavior.

Steps to Reproduce

  1. Activate the Twenty Twenty-Three (TT3) theme.
  2. Open the Site Editor.
  3. Click anywhere in the content area to edit.
  4. Open the Global Styles UI.
  5. Select Blocks menu.
  6. Select Button.
  7. Select Shadow.
  8. 🐞 Select Shadow > which will open the Shadow modal popup.

Expected Results

When testing a patch to validate it works as expected:

  • ✅ The Shadow modal popup should include tools.

Supplemental Artifacts

When reproducing a bug:

  • ❌ The Shadow modal popup is empty, i.e. no tools.

Test Report Icons:
🐞 <= Indicates where issue ("bug") occurs.
✅ <= Behavior is expected.
❌ <= Behavior is NOT expected.

Version 0, edited 17 months ago by hellofromTonya (next)

#11 @hellofromTonya
17 months ago

  • Keywords needs-testing removed

Test Report

Patch: https://github.com/WordPress/wordpress-develop/pull/4114

Environment

  • OS: macOS
  • WordPress: trunk
  • Localhost: wp-env (with Docker)
  • Browser: Firefox, Edge, and Chrome
  • Theme: TT3
  • Plugins: none

Actual Results

Before Applying the Patch

trac57708-before.gif shows it in action.

Yes, can reproduce the reported issue ✅

After Applying the Patch

trac57708-after.gif shows it in action.

Yes, the patch resolves the issue ✅

#12 @hellofromTonya
17 months ago

  • Keywords commit added

Patch: https://github.com/WordPress/wordpress-develop/pull/4114

Ready for commit 👍 Prepping now.

#13 @hellofromTonya
17 months ago

  • Resolution set to fixed
  • Status changed from reviewing to closed

In 55405:

Themes: Add 3 and update 2 shadow presets in theme.json.

Adds Deep, Outlined, and Crisp default shadow presets to Core's theme.json file.

Updates the Natural and Sharp 'shadow' styles.

These shadow presets are used to populate the Shadow tools in the Site Editor's Global Styles UI.

References:

Follow-up to [55176].

Props franz00, madhudollu, ajlende, beafialho, costdev, dhrupo, fabiankaegy, hellofromTonya, jameskoster, joen, kellychoffman, mamaduka, mtias, oandregal, priethor, richtabor, scruffian.
Fixes #57708.
See #57559.

@Mamaduka commented on PR #4114:


17 months ago
#15

Thank you, @hellofromtonya!

Note: See TracTickets for help on using tickets.