Make WordPress Core

Opened 16 months ago

Closed 16 months ago

Last modified 14 months ago

#57845 closed enhancement (duplicate)

Allow Revision History of a post to be viewed even if user doesn't have edit permissions

Reported by: shadowxvii's profile ShadowXVII Owned by:
Milestone: Priority: normal
Severity: normal Version: 6.1.1
Component: Revisions Keywords:
Focuses: Cc:

Description

Some of my users find it useful to go back and see changes from previous versions of a page when editing other pages.

This can't be done unless the user has Edit permissions, even if they have Read permissions for a given post type.

The revisions.php should allow view-only access to the history if the user has read instead of redirecting them to the posts list edit.php.

Change History (2)

#1 @ShadowXVII
16 months ago

  • Resolution set to duplicate
  • Status changed from new to closed

Actually this might be a dupe of #40577

#2 @desrosj
14 months ago

  • Milestone Awaiting Review deleted
Note: See TracTickets for help on using tickets.