Make WordPress Core

Opened 13 months ago

Closed 13 months ago

Last modified 13 months ago

#57919 closed defect (bug) (duplicate)

sprintf() needs more than 1 arguments

Reported by: aristath's profile aristath Owned by:
Milestone: Priority: normal
Severity: normal Version:
Component: Comments Keywords: has-patch
Focuses: Cc:

Description

This is a backport of https://github.com/WordPress/gutenberg/pull/49054, reported in https://github.com/WordPress/gutenberg/issues/49000

In src/wp-includes/blocks/comment-template.php we have $block_content .= sprintf( $inner_content ); which will throw a PHP error because sprintf() expects at least 2 arguments.

Change History (6)

This ticket was mentioned in PR #4232 on WordPress/wordpress-develop by @aristath.


13 months ago
#1

  • Keywords has-patch added

#2 @ocean90
13 months ago

  • Milestone 6.2 deleted
  • Resolution set to duplicate
  • Status changed from new to closed

While this already has a PR assigned I'm going to mark it as a duplicate of #57883 since it has a few more details.

@audrasjb commented on PR #4232:


13 months ago
#3

Hey @aristath thanks for the PR but AFAIK, this file shouldn't be edited directly in Core. This probably has to be fixed on Gutenberg's side only and merged into Core via a package update.

@aristath commented on PR #4232:


13 months ago
#4

I wasn't clear on the process now that we're on RC, that's why I created the separate PR for Core... Just in case it's too late for automated package updates (there's a lot of confusion around what goes where, until when etc)

@Mamaduka commented on PR #4232:


13 months ago
#5

The changes will be part of the package update. We can close this PR and related Trac ticket.

#6 @SergeyBiryukov
13 months ago

  • Component changed from General to Comments
  • Summary changed from sprint() needs more than 1 arguments to sprintf() needs more than 1 arguments
Note: See TracTickets for help on using tickets.